Highlighted
srkiNZ84
1 Nickel

Error upgrading MD1000 firmware

Hi,

I'm trying to apply a firmware upgrade to a MD1000 enclosure for it to be able to recognise some Seagate drives (model #ST3600057SS). The upgrade can be found here. My problem is that the firmware update is only available as an .exe file (as opposed to a .df which you can load through Modular Disk Storage Manager.) and when I run it on Windows Server 2008 R2 SP1, it refuses to install, giving the following error:

<< PACKAGE LOG >>Running validation...

No custom validation configuration file found (CVConfig.xml)

<SVMValidation lang="en" ><System systemID="0235" ></System><OperatingSystem osVendor="Microsoft"  osArch="x64"  majorVersion="6"  minorVersion="1"  spMajorVersion="1"  spMinorVersion="0" ></OperatingSystem><Validation type="qualification"  result="false" ><Message>This Update Package is not compatible with your system configuration.</Message></Validation></SVMValidation>

<< PACKAGE LOG >>This Update Package is not compatible with your system configuration.


<< PACKAGE LOG >>==============================> Update Result <==========================

Update was not applied

How can I apply this update? If the executable is compatible with Windows Server 2008, I was thinking of just creating a custom "CVConfig.xml" file to just workaround the validation checks.

Has anyone run into this problem before? If so, how did you solve it?

Thanks

0 Kudos
2 Replies
Dev Mgr
6 Gallium

Re: Error upgrading MD1000 firmware

That link is for drive firmware for a 600GB Seagate drive, not for an MD1000.

The MD1000 firmware is available from, but it's 4 years old (which is actually pretty good as it means it's stable and didn't take Dell 20+ revisions to get there (like the PV220S)).

Member since 2003

0 Kudos
srkiNZ84
1 Nickel

Re: Error upgrading MD1000 firmware

Yes, the link is for the firmware for a 600GB drive. These are the drives which we have put into the MD1000, but are regarded as "Uncertified" by the MD1000. The firmware I've linked to previously is supposed to be applied to the MD1000 allow it to recognise and make use of the drives, by going to the "Modular Disk Storage Manager" -> "Support" -> "Download Firmware" -> "Download Physical Disk Firmware".

I've tried installing the software which you've linked to (even though the MD1000 is running the A04 firmware already) and got the same error during the install again, namely:

This Update Package is not compatible with your system configuration.

So, it seems that neither of these executables is compatible with Windows Server 2008 R2.

0 Kudos