Highlighted
Alstarian
Not applicable

Issues with cleaning the TL4000 Drives

Hello,

I have a TL4000 and the 4 drives show up as "Dirty" in the Web Interface and require cleaning becasue till that is done the backup software that we use (Netbackup) will not start.

I will an error in the logs of the Netbackup software that the cleaning must be done.

I inserted a cleaning tape in I/O SLOT 1 and when I move it to any of the 4 drives of my libarary the cleaning does not start which is odd becasue I have done this before and as soon as I would move the CT in the drive the cleaning would start but not in this case.

So i tried with another cleaning tape maybe the first one was broken or damaged but even the second one did not work and the cleaning does not take place.

Now 2 cleaning tapes cant be broken at the same time can they? Does anyone have an idea as the what is going on?

I have rebooted the libarary multiple time but to no avail!

Thanks in Advance

 

0 Kudos
6 Replies
Moderator
Moderator

Re: Issues with cleaning the TL4000 Drives

Alstarian,

The issue may be that the driver and firmware for the TL4000 is out of date and it is causing a false errors.

Would you update them and then see it the issues clears? I am not sure of the specific OS you are using. These are Windows Server 2008 R2 versions.

TL4000 Driver -

TL4000 Firmware -

If this isn't the OS you are using let me know and I will post the correct ones for you.

Chris Hawk

Dell | Social Outreach Services - Enterprise
Get Support on Twitter @DellCaresPro 
Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

0 Kudos
Alstarian
Not applicable

Re: Issues with cleaning the TL4000 Drives

I am using Windows 2008 Server Standard edition where my Netbackup software is installed.

Will this firmware update work on them too?

0 Kudos
Moderator
Moderator

Re: Issues with cleaning the TL4000 Drives

Yes, the firmware should be the same.

This is the 2008 Standard NON R-2 Driver -

Let me know how it goes.

Chris Hawk

Dell | Social Outreach Services - Enterprise
Get Support on Twitter @DellCaresPro 
Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

0 Kudos
8 Krypton

Re: Issues with cleaning the TL4000 Drives

Sorry in advance for all these questions, but the more we know about the behavior the easier it will be for someone to diagnose.

What is actually happening when the tape is inserted into the drive? any LEDS flashing on the unit...

Is there any message being displayed in the web interface or the front panel display?  during and after the operation.

Are you having to manually move the tape back from the drive to the I/O slot to retrieve it?

When you perform the cleaning are you stopping any backup application services to the library, to insure that the application has no control over the unit?

The OS driver will have no effect on the cleaning operation. The drive will recognize the tape internally and begin a clean operation. The correct driver to use for your library in your setup is the Native MS drivers (INBOX) for both the drive and the medium changer. If the OS is unable to load a native driver for the LTO drives there is an MS Hotfix that updates the tape.inf. (don't have the # handy sorry)  The Dell provided driver should only be used if data path failover is required, this is a licensed feature of the library... this is all documented in the README.txt

-Bob

0 Kudos
8 Krypton

Re: Issues with cleaning the TL4000 Drives

Let me clarify my driver statement. If NETBACKUP has a driver installer as part of the software you should be using that as your first choice. If there is no driver installer then you need to use the native OS driver.

Bob

0 Kudos
AbdulRasheed127
Not applicable

Re: Issues with cleaning the TL4000 Drives

Hi Bob,

  Assuming that it is a 64 bit Windows, NetBackup uses the native driver. Symantec used to provide own drivers during 32 bit OS days.

Warm regards,

Rasheed

 

0 Kudos