PowerVault

Start a Discussion
3 Silver

md3200 has different nvsram version on two controllers

it's also reporting that one of the controllers has a failed battery.  have ordered a replacement battery.

I get a strange error (no actual text) when I try to upgrade the firmware - I assume it will be this way until we have the battery situation sorted out?

the array continues to appear to function properly, albeit a bit slow (although we are running raid 6 and I assume the caching is disabled for now due to the battery issue).

controller 0 reports 07.84.56.60 and nvsram n26x0-784890-004

controller 1 reports 07.84.56.60 and nvsram n26x0-775890-009

Replies (10)
Moderator
Moderator

Hey, Wes.

You could go into MDSM, and upgrade the NVSRAM only. In order to upgrade the NVSRAM on the other controller, you'll need to go through the exact same process as upgrading the firmware. In MDSM, at the top of the screen, hover over "Upgrade", and select, "RAID controller module NVSRAM". (BE sure they match)

Page 192 in this  Owner's Manual goes into detail on transferring the NVSRAM to the controller:

downloads.dell.com/.../powervault-md3200_Owner%27s%20Manual_en-us.pdf

Let me know if that takes care of it. Have a good rest of the day!


DELL-Sam L
Social Media Support Enterprise
#IWork4Dell

3 Silver

Hi Sam - thanks, I should have stated we receive the same error regardless of updating firmware or nvsram.

We replaced the battery and now the entire array is showing optimal.

We were prompted to clear out the event log, which we did, but we still receive a strange error when trying to update either firmware or nvsram:

MD3200 - Data Validation Error

then in the box is a red circle with an X in it, but no further text or anything - just the box to click ok.  So it is telling us nothing useful on what the actual error encountered is.

Any idea what to try next?

thanks!

3 Silver

3 Silver

Hi Sam, any thoughts on this?  Thanks!

3 Silver

bump

3 Silver

bizzump

Moderator
Moderator

Hello, wlazara.

So, what I'd try next is pulling the RAID Controller in slot 0, and give it like 10 to 15 minutes before re-seating it. You don't have to pull it all the way out, just enough to break it off the mid-plane.

The sync should match it up to the new version.  

(or have you don't this part already?)

3 Silver

Hi Daniel, we continued to have battery issues with that controller so we just went ahead and completely replaced it.

The new controller has nvsram version 009, but the old one has 004.  They do not appear to be coming into sync on the same version.

I still get the blank data validation error in the screenshot above when trying to upgrade any aspect of the firmware or nvsram.  Any thoughts?

thanks,

Wes

Top Contributor
Latest Solutions