Precision Fixed Workstations

Last reply by 02-21-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

5820 bios update 2.0.2 Jan 20 stuck at 0%

I had to disable the dell command update. It keeps trying to install the critical 5820 bios update Version 2.0.2  dated 20 Jan 2020.

The bios installer reboots and then gets stuck at 0%. I have reset the bios to factory settings. Bit locker is not on. 

This has happened about six times, 4 via the dell command update and twice trying to manually update the bios from the installer on the support page for the service tag. The last time it failed I went home at 5 PM and it was still at 0 % at 8 AM. I have previously updated the bios on this workstation 3 or 4 times with no problems. I have made no hardware changes.  Fortunately, I can hit the power button and restart and get back into windows.

Has anyone else experiences this? Any solutions?



Current Bios 2.0.1

Dell 5820 256GB RAM Quadro P6000 24GB Xeon W-2135

Solution (1)

Accepted Solutions
2 Bronze
2 Bronze

Thanks to this forum I was able to resolve the issue.  Dell TS wanted to replace the motherboard, I knew there had to be a better solution.  These are my notes to resolve.

Issue: Dell Command Utility could not upgrade BIOS from 2.0.2 to 2.5.0.  Would fail at 0%.


  • Confirm/turn off Bit Locker (it wasn't on).
  • Remove cable for monitor 2 and 3.  (these are all Display Port Monitors)

  • Set resolution for monitor 1 to 1920x1080. (lowering resolution worked, didn't need to find an old one)
  • Reboot PC > press F12

    • Bios Setup

      • Secure Boot > disable

      • Advanced Boot Option > Enable Legacy option ROMs

      • Boot Sequence > select Legacy

      • Reboot

  • No boot device found press any key > pressed space > rebooted > no boot device found press any key > no boot device > 3rd time pre-boot performance test (about 3 minutes) > rebooted > no boot device > rebooted > press F12 > select windows boot manager > now I was able to get to a Windows log on.
    -So you can just F12 and select windows boot manager to get to Windows.

  • Click link to Dell Drivers page > Bios > download and run Bios 2.5.0 updater from windows (didn't need to use a USB drive) > system rebooted to BIOS update progress > yes, it's finally updating (about 5 minutes) > rebooted > no boot device found > I rebooted to confirm 2.5.0 bios version
  • I rebooted again > F12 > Bios Setup
    • Secure Boot > Enable
    • Advanced Boot Option > Uncheck Legacy option ROMs
    • Boot Sequence > change back to EUFI
    • Rebooted > right to windows log on.  Excellent.
  • Ran Dell command update > system up to date
  • Issue resolved.


View solution in original post

Replies (74)
2 Bronze
2 Bronze

It's happening to me too, stuck at 0%. I was able to restart the machine. It is a 5820 with 64GB, W-2135. 

2 Bronze
2 Bronze

I seem to be having the same issue. At the moment I am not brave enough to interrupt the BIOS update process, which is stuck at 0%. This is using "flash bios" from a usb stick.

I note that I am also trying to update from BIOS 2.0.1, the same as you.

It seems that Dell withdrew BIOS 2.0.1, ref

I hope this upgrade path has been tested...


I forcibly powered off the system, and it still boots with the old BIOS (2.0.1). Phew!

3 Argentum

Apart of waiting for an official answer from Dell for those customers that downloaded the now withdrawn BIOS version 2.0.1, there are two workarounds that may work but are somewhat risky:

  1. Downgrading the current BIOS (if it is yet possible once 2.0.1 has been applied) and try reflashing 2.0.2 then.  It seems this BIOS version does not offer a list of "previous" BIOS releases on the Dell support page, so I fear the only way to get an earlier one will be from the now outdated Dell Precision Tower 5820 product support web page (not updated since mid-2019).  There is a possibility Dell has removed the digital certificate used to authenticate earlier firmware releases, so this method may not work.
  2. Trying to force a reflash of 2.0.2 using one of the BIOS Recovery options on a Dell workstation.

I would say method (2) is, possibly, safer than downgrading and then upgrading.

2 Bronze
2 Bronze

I have the same problem with my T5820. PC reboots then sits there at 0% for 1/2 hour or more without progress bar moving at all. BIOS update should take a few minutes. I powered off PC and reboot. System Info shows previous BIOS.

  Just incredible! How could DELL release a BIOS update for a T5820 Business Class Workstation WITHOUT even testing it?


(Working with PC's since Jan 1987)

<Email id removed>


Greetings All. I too had the dreaded 2.0.1 Bios and experienced the same frustration as everyone else with it refusing to flash

Here is what I did to get my 5820 to accept the new flash

1. Created a bootable usb drive per the instructions here

After that I copied the new 2.0.2 bios to the flash drive and rebooted. Use F12 to get to the bios boot menu. There is an option to update the firmware. I choose that and we presented with a screen where I had to choose the file manually, once I selected the BIOS file I went through the usual nag screens of accepting the flash, the system rebooted and flashed right away.

Pro Support was going to send out a replacement MB, but I asked them about flashing from a thumb drive, they were good with that:)






It makes sense.  I would never try a firmware update from a live operating system, not to say a Microsoft one.  There are too many variables than can turn a simple update process into a nightmare.  A firmware update from a USB flash drive (either a FAT-32 formatted one on recent workstations, or one running the Dell Real-Mode Kernel operating system for older hardware) is much safer.

The only reason I have not suggested using a FAT-formatted USB drive in a previous post is that GlennMorris was using this update method, and got stuck at zero percent too.

Glad to see you were able to update the BIOS using a flash drive.


Oh, I see the link you mention.  It shows how creating a bootable USB flash drive running DRMK operating system.  It should not be really required, any FAT-32 formatted drive would do the trick.  Note that you have not really booted from that drive, but used a flash updating tool provided by the firmware of your workstation.  A non-bootable USB drive would have been enough.


I tried a bare thumb drive formatted to fat32 but I couldn't get the flash tool to see it. I wasn't successful at forcing a bios recovery either. Here is another Dell article about flashing a 5820 from a thumb drive, it does say that you need a bootable thumb drive - who knows.

Do you know if GlenMorris tried this with the DRMK os?




Latest Solutions
Top Contributor