Precision Fixed Workstations

Last reply by 02-21-2022 Solved
Start a Discussion
2 Bronze
2 Bronze
40164

5820 bios update 2.0.2 Jan 20 stuck at 0%

I had to disable the dell command update. It keeps trying to install the critical 5820 bios update Version 2.0.2  dated 20 Jan 2020.

The bios installer reboots and then gets stuck at 0%. I have reset the bios to factory settings. Bit locker is not on. 

This has happened about six times, 4 via the dell command update and twice trying to manually update the bios from the installer on the support page for the service tag. The last time it failed I went home at 5 PM and it was still at 0 % at 8 AM. I have previously updated the bios on this workstation 3 or 4 times with no problems. I have made no hardware changes.  Fortunately, I can hit the power button and restart and get back into windows.

Has anyone else experiences this? Any solutions?

Thanks,

Mark

Current Bios 2.0.1

Dell 5820 256GB RAM Quadro P6000 24GB Xeon W-2135

Replies (74)
18689

It wouldn't let me downgrade from 2.0.1.

Selecting "Flash BIOS" from the F12 menu remained stuck at 0%.

Following the "BIOS Recovery" steps worked like a champ.  I'm now at 2.0.2.

8110

@steve344 

Try turning on the workstation with the USB flash drive connected to one of the front ports.  I have seen workstations that had problems seeing drives connected once the computer was turned on.  You may want trying another flash drive too, a lower capacity one.  Make sure it is FAT32-formatted, not NTFS, ffs or ext4.  The article you mention is for the OptiPlex 9010, an old desktop where bootable media was probably required.

There is no magic, DRMK is not required if you will not boot from the USB drive.

11585

@Kernel Builder 

Glad to see the BIOS recovery procedure helped.  Some people had luck flashing BIOS from a USB drive, using the standard firmware upgrade procedure, but it failed to you.  That is odd.  In any case, it is nice to see that you are running 2.0.2 right now.

2 Bronze
2 Bronze
5794

I had a similar experience - it was stuck on 'Saving Manifest' for about 30 minutes after which I forced shutdown my system. I followed the directions in the URL's posted here to apply the update using a USB key and only the 'BIOS Flash Update' method from boot options brought me close enough to apply. The update itself didn't apply - it was stuck on 'Updating your firmware' for over 20 minutes, Flash Progress never went above 0%. After I forced shutdown again and booted into Windows (luckily), re-ran the BIOS updater and BIOS still showed stuck on 2.0.1 - didn't complete the install, just wanted to check what the installer was detecting.

I spoke with Dell support and my only two options were:

  1. Re-install the OS - not sure how this would've helped with a firmware update that clearly couldn't install via a BIOS Flash Update from the boot menu.
  2. Replace the motherboard

I went with the motherboard replacement - should have it by tomorrow, or early next week with an onsite tech. I definitely believe there's a bug in this firmware update that's going to cause this issue with more users of this system type.

5696

For the record, I also ended up doing a motherboard replacement.

I have three 5820s. One was on bios 1.11.1, and two were on 2.0.1. The one on 1.11.1, and one of the ones on 2.0.1, updated to 2.0.2 no problem. The third was stuck at 0%. I have no idea what was different about this system. Resetting to default BIOS options did not help. The "BIOS recovery" technique suggested above did nothing for me (power light flashing amber 3 times, then white 3 times, no display output).

To cap off the saga, the replacement motherboard that was installed today (after two days of missed service visits) was apparently DOA. So now I have to wait for yet another replacement... I hope the rest of you have better luck!

I guess the moral, is, wait a few weeks after release before installing a new BIOS version...

5676

Another successful upgrade from 2.0.1 to 2.0.2 using BIO recovery procedure:

Ctrl-Esc during startup, with FAT32 USB stick containing "BIOS_IMG.rcv" which is the renamed version of "5820T_2.0.2.exe".

As other have reported, both the live method from Windows10, as well as F12 method get stuck at 0%.

5042

Hi @tl_mdx, thank you for confirming the update has completed. Please private message the system details if you still have any issue.

-Akshatha


#IWork4Dell
Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. To send us a private message, click our DELL-Cares username. Our Forum profile page will then appear. On the right, click "Send this user a private message".

4702

Hi all

We have two T5820, Xeon W-2155, 32 GB Ram, NVIDIA Quadro P4000 8GB.

With one, the biosupdate from 2.0.1 to 2.0.2 went without Problems through the normal live Method with Win10/Dell command Update.

With the second one I've tried all the solutions in this Post (live, bios recovery with "BIOS_IMG.rcv" and flasch Bios from F12 menu) - all stuck at 0%. Luckily I could always power off and the system rebooted with no Problem. Dell Support told me to wait a week and then try again, sadly this didn't work so far.

Any solutions?

4647

I am glad to see that forcing an upgrade from the BIOS recovery mode did the trick for some of you.  I used this procedure in the past recovering my Precision 3420 from a broken BIOS release that was quickly replaced by a working one by Dell staff in mid-august.

My advice, in case upgrading the BIOS is not urgent to you, would be waiting for the next release.  It makes no sense replacing a perfectly working motherboard as a new one will be a waste of money for Dell, a waste of time to you, and a risk of damaging a high-end workstation.  This one looks like a common issue on the latest BIOS for the 5820 workstation.  Lots of customers have described the same problem on this thread, so I would think on a software, not hardware, issue.  Why not let Dell investigate the problem and fix it?

4642

For those that think this BIOS upgrade is really urgent, indeed you are right. The problems fixed on this BIOS release are serious ones. In fact, I am eagering awaiting for the BIOS upgrade for my Precision Tower 3420, that should have arrived two months ago.  It is now planned for march. However waiting for a new BIOS upgrade is a choice that I would hearthly recommend to all of you having problems with the upgrade on the 5820. The next BIOS release will fix more hardware issues, not as serious or numerous as the ones fixed on the current firmware version but important yet.

You cannot depend only on the BIOS upgrades to maintain your hardware secure; in the same way as software, hardware can be protected by good countermeasures and a well though "castle approach". Security has evolved since the nineties were the bastion model was usually enough. Now security must be considered globally, and defense in depth is the way to go.

Latest Solutions
Top Contributor