Highlighted
stefanzman
1 Copper

Booting from Samsun NVMe M.2 w/ DELL T7610 Workstation

 
 

Trying to get a DELL Precision Workstation to boot of the installed Samsung M.2 NVMe 512gb drive after installing Win10 Pro. The install goes fine form a USB drive generated with MediaCreator and booted as UEFI device. It sees the Samsung disk and completes the setup without errors, but the system will find drive or start after initial reboot (USB removed). 

Here is what I have done:

- Updated to latest BIOS
- Enable UEFI mode
- Enabled and Disabled Legacy options
- Enabled and Disabled SATA ACHI and LSI RAID

The BIOS does show a Mass Storage Device in PCI Slot 1. 

After install the Boot Sequence specifies Windows Boot Manager. 

We have reviewed other threads here as well as DELL's link - http://www.dell.com/support/article/us/en/04/sln300820/what-are-pcie-ssds-and-how-to-use-them-as-a-b...

Nothing seems to work, and I am hoping some has an idea. 

I have included some screens below:

 

Labels (4)
0 Kudos
22 Replies
8 Krypton

Re: Booting from Samsun NVMe M.2 w/ DELL T7610 Workstation

This is a late reply but thought I'd post my experience.  I have a T7610, 16-core 3.30 GHz E5-2667, 128GB RAM, Nvidia GTX 1080Ti video card, BIOS A-16 and was using Samgung 860 EVO SSD's in the front drive bays.

I just installed a used Dell Ultra Speed SSD M.2 PCIe x4 Solid State Storage Adapter Card #80G5N with a single Samsung 950 Pro M.2 SSD in my T7610 and it is now my main Win 10 boot drive. I chose the older Samsung 950 Pro M.2 SSD because I’d read that it had a certain software imbedded that would enable booting, fact or fiction?, I don’t know.


I found this Dell webpage to be helpful, especially Method 3: https://www.dell.com/support/article/us/en/19/sln300820/what-are-pcie-ssds-and-how-to-use-them-as-a-...

The procedure went this way: I removed all other installed drives from my T7610 and installed the Dell NVMe card and Samsung 950 500GB M.2 card in PCIe slot #2, then put a Win 10 USB install thumb drive in a back USB 2.0 slot. I started up the computer and F2'ed into the BIOS. In the BIOS screen I went to General>Boot Sequence and re-configured the Boot Sequence so the Win 10 USB stick was the first boot device, clicked on Apply. Then I moved to the Boot List Option> clicked on UEFI>clicked on Add Boot Option and a window opened, in the blank ‘Boot Option Name slot’ I wrote Samsung 950, the ‘File System List slot’ was already populated with the identity of the Samsung 950 in the PCIe slot location, and lastly the ‘File Name slot’ I left empty and clicked the Apply & OK button, the window closed. The Samsung 950 M.2 is now identified for the Windows Boot Manager to see, clicking on the ‘View’ button in the Boot Sequence window will show the Boot Option Name, File System List and File info should be filled in with the appropriate information. Next, in General>Advanced Boot Options, make sure the ‘Enable Legacy Option ROMs’ box is checked. This allows other non-EFI hard drives that will be installed later to be seen and used as storage. Make sure ‘Secure Boot’ is disabled. At this point I have changed the BIOS to see the PCIe adapter card with Samsung Pro 950, theoretically it is identified and bootable so I clicked on the BIOS Exit button to restart.
Upon start up the Win 10 Install began, I followed the prompts and soon Win 10 was being installed on the Samsung 950 Pro (no other hard drives are in the machine) and the computer restarted using the Samsung 950 Pro - I was amazed it was so simple. After that I began installing drivers for components and soon downloaded Samsung Magician to check the 950 Pro and do a R/W test, the score was in the 2400/1500 range. This new score was about 3 times faster than reported when I used a Samsung 860 EVO in the SAS port in the front drive bay. 

After everything was running nominal with the M.2 SSD I installed two 860 EVO's and a standard SATA HDD in the front drive bays which are seen as other drives and can be accessed and used as storage or backup. They cannot be used as Boot devices unless I change the BIOS back to 'Legacy'.  I am not using a RAID configuration.

I have probably forgotten something here but basically that was all there was to it.  It has been 2 days so far and the T7610 has started and performed as usual, it has been restarted multiple times. The M.2 drive is seen in Passmark and the temperature is available.

kikixxx
1 Nickel

Re: Booting from Samsun NVMe M.2 w/ DELL T7610 Workstation

thank you for you experience...  

I did all the steps, windows He has detected samsung 970 pro m.2 and was

 installed but

after finishing the installation , if i left the usb conected the bios go back to the windows installation menu, if i take off the usb a message appears...no bootable devices found. my sistem information.

samsung 970 pro 512gb / m.2 adapter conected on PCie slot 1 3.0 4x
windows 10
rufus for usb windows boot 16gb
no hard drives conected and disabled on bios
using UEFI boot mode

 


thank you..

0 Kudos
8 Krypton

Re: Booting from Samsun NVMe M.2 w/ DELL T7610 Workstation

Sorry for your difficulties. 

Is your BIOS the same as mine (version A16) and does your 970 Pro SSD show in the Boot Sequence of your BIOS now? 

Are you using a Dell Ultra Speed 80G5N PCIe adapter card like I am?

The other difference was I used a Samsung 950 Pro SSD, I read somewhere that was a critical step because it has different firmware that the newer 960/970 Pro models.  I don't have one of the newer ones to experiment with right now.

Edit:  I just looked it up and found that the Samsung 950 Pro 512GB SSD has a Samsung UBX Controller vs. the 970 Pro SSD with a Samsung Polaris Controller.  I'm just guessing but that may make a big difference in bootability to the PCIe adapter card or the Precision T7610's BIOS.

kikixxx
1 Nickel

Re: Booting from Samsun NVMe M.2 w/ DELL T7610 Workstation

thank you, im using this

my system: 

Bios A16

Adapter card (Generic)  : i will change the   Dell Ultra Speed 80G5N PCIe adapter

samsung 970 proi will change the 950 pro

 

I'm debating this issue with technical support because they claim that you can not

if you can send a pictures you helped me a lot... I would greatly appreciate it... 

thank you

0 Kudos
8 Krypton

Re: Booting from Samsun NVMe M.2 w/ DELL T7610 Workstation

All stop...

My system has become corrupted and is not booting correctly from the Dell PCIe adapter & 950 Pro. 

A couple days ago, when the Adapter and 950 Pro were working normally, I tested the system with several different software diagnostics. Samsung Magician software reported the 950 Pro as in good condition, Black Magic disk speed tests were good at 1450/2450.  However, when using Geekbench the overall scores were about 10% less than when running from a SATA Samsung 860 in the front drive bays, this test made no sense to me. 

I had just started using Passmark and the scores were very high, then yesterday the system did not start correctly and I have had to shift back to running this T7610 using the Samsung 860 Pro in the front drive bay. At this point I will have to re-install Windows on the 950 and do more tests to see why these lower Geekbench performance scores and the Windows data corruption are occurring. 

8 Krypton

Re: Booting from Samsun NVMe M.2 w/ DELL T7610 Workstation

I just re-installed Win 10 Pro and the computer is working nominal, all seems okay now.  Here are some pictures of: 1. The Dell adapter in Slot 2 with 950 Pro inside;  2. The BIOS UEFI config; 3. Showing that the BIOS sees the 950 Pro in Slot 2 as Mass Storage; 4. Magician SSD diagnostic's; 5. Write Read speeds of the 950 Pro SSD; 6. Win 10 shows the 950 M.2 as a NVMe device. These pictures show that this Dell PCIe adapter with the Samsung 950 Pro does indeed boot the computer and work. I still don't know why I had the Win 10 corruption problem but things are running smooth now.  That is a Nvidia GTX 1080Ti in Slot 4. 

I built this T7610 system as a lark, just to see if it would work. My advice for anyone attempting this would be to question if this older technology in the Dell adapter and older Samsung 950 SSD is worth the cost and time involved to you.  It has yet to be proven as a mission critical configuration.

I'll continue testing this setup.  

IMG_1795.jpgIMG_1788.jpgIMG_1792.jpgIMG_1793.jpgIMG_1798.jpgIMG_1803.jpg

8 Krypton

Re: Booting from Samsun NVMe M.2 w/ DELL T7610 Workstation

I found this Aplicata M.2 NVMe SSD PCIe x8 Adapter, it looks interesting because it has it own PCI chip onboard, it's expensive though:

https://www.tomshardware.com/reviews/aplicata-m.2-nvme-ssd-adapter,5201-2.html

kikixxx
1 Nickel

Re: Booting from Samsun NVMe M.2 w/ DELL T7610 Workstation

you are a genious ... i am a architect, i use programs like: Sketchup Pro, Lumion 8 , Revit Architecture , 3D max .... but my goal is that every program that i use to work can open files faster, thats why im eager to use MVMe M.2 Technology...  i have just bought a Samsung SSD 860 Pro ,  tell me, the SSD 860 pro between Samsung 950 pro MVMe M.2 , it is a big difference ? 

 

0 Kudos
8 Krypton

Re: Booting from Samsun NVMe M.2 w/ DELL T7610 Workstation

Re: kikixxx: 

Hi, the Samsung 950 Pro M.2 512GB SSD PCI-Express 3.0 x4  in my T7610 has R/W speeds that are about three times faster than the Samsung 860 Pro SSD in the T7610's front SAS port (approx. 2500/1450 vs 525/450). 

Screen Shot 2018-08-09 at 8.29.46 PM.png

Edit:  All T7610 workstations may not be configured the same, this shows my T7610's setup.

1. The storage controller in my T7610.

LSI controller.JPGLSI Adapter

2. The NVMe ControllerNVMe controller.JPGNVMe