ordervschaos
1 Nickel

Intel Rapid Storage Technology driver problems

Hi all, A little history of some problems I have had with the IRST drivers (C600+/C220+ chipset)

 

I have a Precision 5810 and 7810, both with SSDs. On the 5810 it was installed on build, on the 7810 I put in a Samsung SSD later. On both computers I have had a problem where every couple of weeks or so the system with bluescreen with a iaStorB.sys error from the IRST driver. On the 7810 it got much worse at one point, bluescreening 2 minutes after startup. I tried restore and refreshing Windows, but only a complete from and installation from media fixed it. Since then I have had no problems at all. Looking at device manager I see the IRST drivers are no longer installed, presumably because I changed the BIOS settings to use AHCI instead of RAID.

 

I'm about to try the same process with the 5810 (BOIS to AHCI and RAID off, and fresh install)

 

Has anyone else had problems with these drivers?

0 Kudos
3 Replies
Tesla1856
6 Thallium

Re: Intel Rapid Storage Technology driver problems


@ordervschaos wrote:

1. but only a complete from and installation from media fixed it. Since then I have had no problems at all. Looking at device manager I see the IRST drivers are no longer installed,

2. presumably because I changed the BIOS settings to use AHCI instead of RAID.

3. I'm about to try the same process with the 5810 (BOIS to AHCI and RAID off, and fresh install)

4. Has anyone else had problems with these drivers?


1. Good.

If you must run it (because you run a RAID) then keep it updated and be sure you are using the proper version.

2. Right. Also, with AHCI, don't load Intel-RST drivers (and app) into Windows.

3. Yeah, I would.

4. Sure. Just search " (Intel-RST) is optional in a non-RAID environment" for that section.

https://www.dell.com/community/Alienware-General-Read-Only/1-How-to-Clean-install-Windows-7-64-bit-o...

And yes ... I have some systems using newer Intel-RST ... with proper care, they seem to work fine so far .


Registered Microsoft Partner and Apple Developer
- I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
0 Kudos
Dblbassman
1 Copper

Re: Intel Rapid Storage Technology driver problems

Thanks for the helpful advice.  I successfully switched my 7810 over to AHCI.  The system is configured with a Samsung SSD and an HDD.  When I switched the controller driver over to Standard AHCI, the system failed to reboot.  I was fortunate to find a way to get Win 10 to do a repair and re-install the Intel drivers.  Bluescreen issues remain.  Spoke with Dell support.  They are well aware of this issue but would prefer to stick their heads in the sand.  Not acceptable!

0 Kudos
Tesla1856
6 Thallium

Re: Intel Rapid Storage Technology driver problems


@Dblbassman wrote:

When I switched the controller driver over to Standard AHCI, 


As I said above (or in my links) ... I've never seen that "just work" or not lead to boot failure. Try this:
- Switch to AHCI
- Clean install Windows-10
- Never install Intel-RST or anything like it.

 

 


Registered Microsoft Partner and Apple Developer
- I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
0 Kudos