Precision Fixed Workstations

Last reply by 08-14-2021 Unsolved
Start a Discussion
2 Bronze
2 Bronze
3159

Precision T7610 USB 3.0 Not Working Win10 x64 Install

I recently picked up a refurbished Precision T7610. Installed Win10 x64. The problem is the USB 3.0 ports both rear and the one on the front panel do not work. Plug a USB drive that is USB 3.0 and tried a USB 2.0 drive both have lights to show that it is getting power but on any of the USB 3.0 ports the system doesn't recognize anything plugged in.

I checked cabling and its fine. Win 10 is supposed to have USB 3.0 native drivers. The Dell support site is no help. No firmware/driver information for USB 3.0 on this motherboard.

Details:

Latest BIOS A17 installed

USB 3.0 enabled in BIOS

All latest Windows 10 updates installed

Dell check for driver updates says I have all the latest drivers.

Device Manager doesn't mention any USB 3.0 host controllers that I can see.

 

Reaching out to the community for help. Anyone know how to fix this?

Labels (3)
Replies (10)
2 Bronze
2 Bronze
2964

Here is a couple of screenshots from device manager.

chipset_devicemanager.PNGusb_devicemanager.PNG

 

 

2942

Hello so I see that there are no Windows 10 USB 3.0 drivers installed in your photo you included on Dell’s Forum site. And I see that Dell does not offer drivers for the USB 3.0. But if you look at the drivers for the Windows 7 x64 the controller is NEC (Renasys) USB3.0 xHCI. So I suggest downloading and installing the Windows 7x64 driver link below: https://www.dell.com/support/home/us/en/04/drivers/driversdetails?driverId=MY3VD&osCode=W764&product... After install you should see a renasys xHCI driver loaded under the USB and your ports should work fine. Let us know what you find.
2934

@Cazzbar 

Thanks for the reply. I installed it but no luck. Device Manager still doesn't show USB 3.0 host and no device works plugged into any of the USB 3.0 ports both front panel and back panel. Also tried multiple devices USB 2.0 and 3.0 since they are supposed to be backwards compatible. 

Yes it is enabled in the BIOS.

Any other ideas? 

2926

Did you load the Windows 10 in UEFI mode? See if you can use a Windows 10 bootable USB drive in a USB 3.0 port. And press F12 and see if the USB drive is recognized under UEFI and if it boots to your USB key. If it does this would mean the USB 3.0 ports are working, it would definitely be a software/driver issue. Let me know what you find. 

2264

Greetings! I use a T7610 as my workstation as I am a repair tech and I've been having growing issues with this as well. It seems I can get power out of the ports, but no data connectivity while booted into Windows 10 Professional. I tried booting to a USB drive in the front 3.0 port and it worked with Secure Boot On. I have also tried uninstalling the drivers and rebooting. I'm fully up to date with Version 1903 w/ OS Build 18362.356. Are there any other solutions that need tried? I'm all ears! ^_^

2007

My T7610 USB 3 Ports Bricked After Bios Upgrade from A10 to A18.

1 Front and 3 Back USB 3 ports Providing Power to charge phone or mouse lights. but no mouse keyboard USB working in BIOS, DOS or Windows Envoirnment. USB 3 also not showing in daignostics or in Device Manager.

 

Please consider giving posts you like a thumbs up.
Please "Accept as Solution" posts that are a solution.

I'm a big fan of Dell, a Dell user, and not an employee
1639

Hello,

my USB three ports are also not working both front and back. It seems I have the exact same issue as you and the other gentleman. I have tried multiple fixes, reinstalling chipsets, also tried to install the Renesas /nec controller; Nothing seems to work. This is going on for many months so I’ve continued  to use the USB 2 ports which still work. I have A19 bios and the current Windows 10 updates. A Dell tech said that Microsoft may have discontinued support for this controller so that’s why it is not installing any drivers or software for the chipset. That seems unusual since this controller is used in a lot of third-party add- in cards and other computers. If you found any resolution over the last few months please post. Thanks

2 Bronze
2 Bronze
1177

Hey guys, anyone found a solution yet? I'm having the exact same issue.

1000

Same problem here

How to get attention from the Dell support ?

Latest Solutions
Top Contributor