bgrommel
1 Copper

Re: Precision Tower 3420 not booting in AHCI after BIOS upda

Jump to solution

I am also having this issue with the new BIOS.  Installed from a Windows 10 OS.  The computer just didn't boot after the update.  On a cold boot the rounded Dell logo remains forever.

0 Kudos
MCV123
1 Copper

Re: Precision Tower 3420 not booting in AHCI after BIOS upda

Jump to solution

We have experienced the same phenomena on almost 150 Precision 3620s after applying BIOS 2.10.2.

We found both the BIOS Flash Utility and Dell Diagnostic tools to hang indefinitely after applying 2.10.2 too. We have been able to recover these devices manually using the following steps: 

  1. Create a bootable USB stick (using Rufus) containing a known working version of BIOS, we used 2.7.3
  2. Disable SecureBoot
  3. Enable Legacy Boot ROMs
  4. Reboot -> F12 to One-time boot menu
  5. Run known working BIOS executable
  6. Reboot (BitLocker Recovery Prompt sporadically appeared)
  7. Disable Legacy Boot ROMs
  8. Re-enable SecureBoot

 

We currently have an open ticket with Dell Support, and have escalated to our account manager.

8 Krypton

Re: Precision Tower 3420 not booting in AHCI after BIOS upda

Jump to solution

Just an advice for those of you who had problems after updating BIOS to version 2.10.2.  In my humble opinion, the easiest way to return to BIOS version 2.8.1 is:

  1. Download the old BIOS updater (e.g. Precision_Tower_3420_2.8.1.exe) from support.dell.com and copy it to a FAT32-formatted USB stick;
  2. on the BIOS setup change the SATA operation mode from "AHCI" to "Disabled" (this step ensures the One-time boot menu is reachable again);
  3. restart the computer and, from the One-time boot menu, choose update BIOS;
  4. reflash the firmware using the BIOS updater stored on the USB stick; and, finally,
  5. go into the BIOS setup again and restore the old SATA operation mode ("AHCI").

Note: the FAT32-formatted USB stick does not need to be bootable.

Splug
1 Copper

Re: Precision Tower 3420 not booting in AHCI after BIOS upda

Jump to solution

Ran into this issue on non-Dell provided 18.04 after Ubuntu Software Update Center offered a Firmware Update for the Dell Precision Tower 3420 - I can confirm rolling back firmware from 2.10 to 2.08 after disabling AHCI mode for SATA worked in restoring this system. I was not able to launch the Dell BIOS Flash utility with AHCI enabled.

0 Kudos
tkelliher
1 Copper

Re: Precision Tower 3420 not booting in AHCI after BIOS upda

Jump to solution

I can confirm that I've had the same problem with the 2.10.2 BIOS on a 3620 running Windows 10 Pro.

Disabling Secure Boot and enabling the Legacy Option ROMs allowed me to boot, from which I reverted to the 2.8.1 BIOS.  I can use Secure Boot with the 2.8.1 BIOS.

0 Kudos
jonsix
1 Copper

Re: Precision Tower 3420 not booting in AHCI after BIOS upda

Jump to solution

I can confirm too that the same issue occurs on Precision Tower 3620 with the 2.10.2 BIOS, running Ubuntu. BTW, on Ubuntu the firmware updates are automated and only requires one confirmation only to reboot to a nasty surprise.

I'm glad that there's a workaround but how long will it take Dell to at least remove the faulty firmware from the website?

0 Kudos
8 Krypton

Re: Precision Tower 3420 not booting in AHCI after BIOS upda

Jump to solution

Hi jonsix.

I do not trust on a firmware update —or, in general, any sort of update— that is not under my control.  This one is the reason I disable the "UEFI Capsule Firmware Updates" feature in the BIOS setup.  I like downloading firmware updates from what I consider trusted sources (usually from two or more randomly choosed networks over the city) and verify checksums (MD5, SHA1 and SHA256) before applying them from a FAT32-formatted USB stick.

I understand this plan is a nightmare for corporations that want to update hundreds of workstations quickly and easily, but works for me as I have no more than a few computers.

Edit: I am aware of Dell's Signed Firmware Update functionality and how it is used for BIOS update authentication and anti-rollback support enforced by signing keys revocation.  This feature is great, but I want full control over the update process yet.

0 Kudos
akvinny
1 Copper

Re: Precision Tower 3420 not booting in AHCI after BIOS upda

Jump to solution

@tkelliher wrote:

I can confirm that I've had the same problem with the 2.10.2 BIOS on a 3620 running Windows 10 Pro.

Disabling Secure Boot and enabling the Legacy Option ROMs allowed me to boot, from which I reverted to the 2.8.1 BIOS.  I can use Secure Boot with the 2.8.1 BIOS.


Identical problem on a freshly unboxed and freshly imaged Windows 10 Enterprise 3420. As soon as I applied BIOS 2.10.2, I could no longer boot exhibiting all the same symptoms here. I disabled Secure Boot, enabled Legacy Option ROMs and was able to boot back into Windows. I then downgraded to 2.8.1, and was able to turn on Secure Boot again and disable Legacy Option ROMs. There clearly seems to be some problem with this BIOS version.

0 Kudos
Moderator
Moderator

Re: Precision Tower 3420 not booting in AHCI after BIOS upda

Jump to solution

 

Hi Guys,

Just to let you all know that the issue is being addressed by the BIOS team and a new release will resolve the issue (for both the 3420 and 3620)

Unfortunately I'm unable to provide an ETA for when the new versions will be released.

Thanks.


DELL-Alasdair R
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 10am-5pm GMT (BST)
Get Support on Twitter @DellCaresPro


0 Kudos
Highlighted

Hit F12 SEVERAL TIMES Was: Precision no boot

Jump to solution

Hi,

I was about to fetch the heavy duty toolbox and take hard-drives with SATA/SDD ACHI or whatever name is interfaces out and so on...during a sunny day, 500 m from the beach...and not particularly eager to spend it doing just that.

Enjoy this tip, I was lucky to stumble on in-between a lot of text, before you too end up there,

When they tell to: CTRL-ALT-DEL and then F12 to get into BIOS realms then the magic not mentioned is:

     HIT F12 SEVERAL TIMES - once will not do it.

After this the machine enters its usual talkative mode and can be convinced to do your biding with a little messing around!

I write this post from it after having just done the above, disabled the security heavy armour but not the ACHI (or what it is called) for the solid state SATA disk — as this is disk with root file system hence booting with software just on home file system would most likely only result in an ability to play tetris or chess the remainder of the day I suppose and that would not be very helpful progress to relax on as backdrop.

That worked; now I shut it down, and fix the rest to night and run my experiment again 🙂

System: Ubuntu 18.04 LTS freshly unattended auto-upgraded from 16.04 LTS and then equally unattended firmware upgraded from Dell repository; Machine is Precision Tower 3420 with SSD NVem and SSD/sata (or what those acronyms are, I type from memory, you know what it is: The cool small silent internal solid state disks).

Yours

Michael

0 Kudos