9jack9
1 Copper

T7600 10Gbps SFP+ Compatible Cards?

I have a Dell T7600 workstation, and I'm trying to find a compatible SFP+ ethernet card.

Installing an Intel X520-DA2 card into my Dell T7600 has resulted in me not being able to boot, or even enter the BIOS setup screen.  I have BIOS A16 installed.  The failure mode is identical to that described in this post:

https://www.dell.com/community/Precision-Fixed-Workstations/Dell-Precision-T5600-with-Dell-X540-T2-1...

I have a flashing cursor in the upper left corner of the display.  A moderator, Dell-Alasdair R posted about a BIOS incompatibility, which is what I suspect is occurring with me.

Is there a compatible SFP+ ethernet card for the T7600?  Ideally with an intel chipset (for linux compatibility).

 

Thanks,

Ogi

 

 

 

Labels (3)
0 Kudos
6 Replies
Highlighted
Techgee
3 Zinc

Re: T7600 10Gbps SFP+ Compatible Cards?

I believe a flashing cursor means the system is waiting for a boot device to be connected.

I'd check BIOS for anything related to Legacy booting or booting from the network and try turning it off, especially if you're booting UEFI.

I'd also check Boot order to see if there's anything that can be re-arranged so an add-in card or network isn't before the disk.

0 Kudos
9jack9
1 Copper

Re: T7600 10Gbps SFP+ Compatible Cards?

Pretty sure I had network booting off beforehand; but in this case, I couldn't even load the BIOS settings page, until I powered off the system and removed the ethernet adapter.

0 Kudos
Techgee
3 Zinc

Re: T7600 10Gbps SFP+ Compatible Cards?

That's not good.

Not sure if this would help and seems you'd have to look into it from another machine, but Intel's BootUtil.exe for NICs might be worth looking into.  See Upgrade, Enable, or Disable Flash with the Intel Ethernet Flash Firmware Utility and How to Turn Off Intel Boot Agent or Prevent It from Running.  Or, maybe do something like the reverse of Enable Intel 10 Gigabit Network Cards PXE Boot (I'd get Bootutil.exe from Intel, though, maybe Dell if you can find it on Dell's site).

0 Kudos
9jack9
1 Copper

Re: T7600 10Gbps SFP+ Compatible Cards?

Thanks for the suggestion, I'll give it a go!

0 Kudos
Techgee
3 Zinc

Re: T7600 10Gbps SFP+ Compatible Cards?

Intel links above are available on Intel's X520-DA2 Support webpage under 'Install and Setup", along with other good info.

0 Kudos
9jack9
1 Copper

Re: T7600 10Gbps SFP+ Compatible Cards?

I actually don't have a windows machine handy to run those tools, however the card went into another system (a T7910) and it the system booted without an issue, so I really don't think it's the card.

 

With respect to boot order, the fact that I cannot even load BIOS settings with the NIC inserted indicates there is some compatibility issue in play. 

 

The T7600 system is our oldest, so I'm actually giving up on the effort to get a 10Gbps card in there, as likely that machine will be retired before much longer.  If someone comes across this thread, I would suggest trying a 10Gbps card with a different chipset than the Intel X520 or X540.  Alternatively, if you have a windows machine at your disposal, by all means try flashing the pre-boot image.

 

0 Kudos