MaXaMaR
1 Nickel

T7610 UEFI boot NOT working! Only F12

I've tried everything - with & without SHIM, with & without Secure Mode - nothing works! Internal drives, USB. Only F12 boot works. Will there be BIOS update?
0 Kudos
6 Replies
speedstep
6 Thallium

Re: T7610 UEFI boot NOT working! Only F12

The mass storage F6 drivers are not optional.

Renesas Electronics uPD720201 & uPD720202 USB 3.0 Host Controller are not optional

LSI MegarAID 9271 Driver

https://docs.broadcom.com/docs-and-downloads/raid-controllers/raid-controllers-common-files/80-00163...

INTEL ICH7 ICH8 ICH9 ICH10

Drives attached to Raid Controller MUST HAVE initialized container to install on.

Precision T7610Windows10T2W1WA0204/10/2018965 MBDownload Now

https://www.dell.com/support/home/us/en/04/product-support/product/precision-t7610-workstation/drive...

 

You download Cab File and save to USB Flash drive

You then use 7zip to extract the files.

https://www.7-zip.org/download.html

 

You will have to point to the storage drivers for both intel chipset and LSI Raid Controller if you use one.

DVD.jpgMissing CHIPSET DRIVERS F6 mass storage

You then install windows with WIN10 DVD

https://www.neweggbusiness.com/product/product.aspx?item=9b-32-350-237

 

 

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

0 Kudos
MaXaMaR
1 Nickel

Re: T7610 UEFI boot NOT working! Only F12

Thanks but I use Linux. All OSes (3 things, 2 on internal drives, 1 on USB) are installed and working but only with F12 startup. External install/livecd USB media boot also only works with F12.

0 Kudos
Highlighted
_abednego
2 Bronze

Re: T7610 UEFI boot NOT working! Only F12

What is the boot sequence on the UEFI BIOS of your workstation?

Do you see an error after turning on the workstation or do you see nothing at all on the display? Just a wild guess, it seems the first entry in the boot sequence wants running a non bootable binary in the EFI partition and stops here.  It is odd you can boot from the EFI partition from the F12 menu but not on an unattended boot.

Note 1: my Precision Tower 3420 is able to rebuild the boot sequence automatically, at least with Dell's Ubuntu flavour, once the entries on the boot sequence have been removed.  It automatically makes two entries on next boot:

  1. UEFI: PM961 NVMe SAMSUNG 256GB
  2. Ubuntu

I understand you may prefer not trying it, as each entry has a path to a specific bootloader in the EFI partition.  It all depends how much you have customized your setup.

Note 2: you can try moving one of the bootable entries in the boot sequence (i.e. one of the entries that work from the F12 menu) to the first position on that list, so the UEFI BIOS has a chance to find a valid bootloader on the EFI partition and use it.  Cannot be really helpful here, all my computers (either UEFI or not) have a single entry in their boot sequences to start them from their internal drives.  Each time I want to reinstall them (most of these computers run OpenBSD) I add the "USB HDD" boot option to that list, and remove it after upgrading/reinstalling the operating system.  I had never been a big fan of dual booting.

0 Kudos
MaXaMaR
1 Nickel

Re: T7610 UEFI boot NOT working! Only F12

I've tried changing boot sequence in BIOS + trought efibootmgr - nothing happens, if I add timeout it just waits then as always proceeds to network boot then prints No Boot Device Found.
0 Kudos
_abednego
2 Bronze

Re: T7610 UEFI boot NOT working! Only F12

May this knowledge base article help you?  Dell suggests disabling legacy option ROMs and booting in a UEFI-only environment for 7th. gen. processors forward.  If possible, enable secure boot too.

Edit: I see you computer is from 2014, it is difficult to me tracking how old a Dell computer is just looking at the model number.  Obviously, it cannot have a 7th. gen. processor.  However it may help following the knowledge base article advice.

0 Kudos
MaXaMaR
1 Nickel

Re: T7610 UEFI boot NOT working! Only F12

If I disable legacy ROMs then on-board RAID controller with drives stops working in BIOS - cannot boot from it then. Anyway, boot from USB is not possible too - can't find signed binaries (I put there shimx64.efi, EFI can't find it on booting). Boot from F12 not working this way too.

0 Kudos