Showing results for 
Search instead for 
Did you mean: 

M4700 Not recognising AC Adaptor correctly

I have an issue where my Precision M4700 laptop doesn’t recognise the AC Adaptor correctly.

Not sure if related but instead of using the correct AC adaptor, I plugged in my lesser wattage XPS one which I’ve used plenty of times without issue. It worked fine and used it for several hours then shutdown the laptop as normal.
The next day, docked it at work on the Dell port replicator and noticed it wasn’t charging and didn’t acknowledge the mains power. The battery taskbar icon just shows a battery (no plug on it) and the charging light doesn’t illuminate. I tried both the replicator and the actual laptop adaptor but nothing.
I know these both work but as a double check tried it on a different replicator and a different AC adaptor with the same results
When the laptop is running on battery without the adaptor connected it runs perfect, as soon as the adaptor is plugged in or on the replicator, it goes very sluggish and the touchpad stops working.
I know with a lesser adaptor connected Dell machines reduce their performance to match so I guess that’s what it has done but never noticed any change before and never had it not recognise any power.

I've tried a reset by taking the battery out, unplugged, hold power button for 30 secs then put back battery and adaptor but did nothing.

I’ve checked the BIOS and all settings seem ok, I even compared them to an identical working M4700 and they match, but on mine it says ‘AC Adaptor = Not installed’

I thought flashing the BIOS to an earlier version may help, so I forced it on battery to A10 but made no difference, so put it back to A18

Running the start-up diagnostic (F12 on boot) without an adaptor connected throws up what you’d expect:

and under charger test:

Running it again with the AC adaptor in but not working the warning goes away:

 and under charger test  it passes but shows power as 1 watt:4.jpg

So it knows an AC adaptor is present but only detecting 1w instead of 240w

Hopefully someone may have a clue what’s going on with this machine

Thanks in advance

0 Kudos
2 Replies

Re: M4700 Not recognising AC Adaptor correctly


Hi wthtaeghaeghtgq,

If you have the same issue on and/or off the dock and with different, known good adapters it would appear there is an issue with the motherboard (or possibly the DC-in cable)

To rule out the DC-in cable you would need to disconnect it from the motherboard and then try the system on the dock to see if the power is then being detected. However, it's not a straightforward job to perform, you need to partly remove the motherboard to get access: (page 48)


DELL-Alasdair R
Social Media Support
I'm based in the UK and I'm usually available Monday to Friday 10am-5pm GMT (BST)
Get Support on Twitter @DellCaresPro

0 Kudos

Re: M4700 Not recognising AC Adaptor correctly

Thank you very much for your reply.

I thought the montherboard may be the issue.
Looking at the pdf i dont think it looks too bad, just very time consuming but as it is, the laptop doesnt work so i will have a go, nothing to lose.

0 Kudos