Highlighted
jbgiraffx
1 Nickel

M6600 Will NOT Boot or Wake with AC Adapter Plugged In

Brief Background: Within the past year or so I was having some common battery/charging problems. I was suffering from "Plugged In, Not Charging". According to the usual checks, the Power Supply appeared to be working properly. I replaced the battery with a replacement model from Amazon - NOT a Dell OEM battery because of the high price. It immediately charged to 100% and worked normally for about a year. Then the error message started again, "Plugged In, Not Charging." During that entire period, the BIOS stated "Battery Not Recognized" AND "Power Supply Not Recognized", even though both were working for awhile. After much trying solutions, I gave up and bought both a new Dell OEM Battery and new Dell OEM Power Supply/AC Adapter. I uninstalled the old drivers and installed both with new drivers. That's the background.
NOW, the new OEM battery is charging perfectly, up to 100%, and running the machine for many hours, as it should. The desktop memo states, "Plugged In, Charging." So far so good. However, the machine will NOT boot, cold boot, reboot or even wake from sleep mode, while the new AC cord is plugged in. If I unplug it, the machine boots and wakes from sleep normally on the battery, but it just goes to a dark navy blue screen and sits there if I try to start it with the AC cord plugged in. NOTE: It's NOT a BSOD. That's a different blue altogether. AND, it will not get to any state where I can press F2, F8 or F12. None of those work while the AC cord is plugged in.
I ran a repair start, reset to an earlier working state and Dell online diagnostics, but got no helpful results
M6600: Windows 7 Pro, BIOS A15
ANYONE HAVE ANY IDEA WHAT THIS IS?

0 Kudos
2 Replies
8 Krypton

Re: M6600 Will NOT Boot or Wake with AC Adapter Plugged In

If it were me, I guess I would try another power supply, specially if yours is a 90W supply. I'd go for 180 or 240Watt. OEM only. On EBAY they are not too too much.

On Amazon, I see there are M6600 DC-in replacement cables. Maybe I'd try one of those first, then another supply if my current supply was 180 or 240W. 

0 Kudos
jbgiraffx
1 Nickel

Re: M6600 Will NOT Boot or Wake with AC Adapter Plugged In

I am also a member of the M6600 owner's board at notebookreview. I posted this same issue there. I received a large number of helpful replies, which enabled me to discover the real problem. On Dell's M6600 page for my service tag, when I click on the Parts and Accessories tab, then the Adapters and Batteries links, Dell's website lists and recommends a 180 watt power supply as my replacement part for the OEM power supply. That is an error. I still have my OEM power supply and it clearly is a 240 watt power supply. The recommended 180 watt power supply is under-powered for this machine. The OEM 240 watt power supply is still available for purchase on a different page, but is not linked as compatible with an M6600. THAT IS CLEARLY A DELL WEBSITE ERROR.

Unfortunately I had already purchased and received the one they recommend before discovering the problem.

I reached out to customer support. I supplied ample proof of their error using screen shots of their own web pages, and the error screens from my machine, etc.  THEY ARE REFUSING TO HONOR THEIR ERROR AND REPLACE THE 180 watt POWER SUPPLY WITH THE 240 watt OEM ADAPTER! THEY STATE THAT IT IS MY FAULT FOR ORDERING THE WRONG PRODUCT. FYI: THE NEW DELL CUSTOMER SUPPORT **bleep**!  BEWARE!

0 Kudos