Highlighted
1 Copper

PRECISION 5520 - Nvidia GPU not detected

Hi all,

I have a strange issue with a Dell Precision 5520 ():

The discrete GPU is not present anywhere in the BIOS settings or in the windows device manager and i cannot install any kind of drivers for the it (tried some from the Nvidia website and all versions from the dell product page).

Have tried reinstalling the OS/older versions of Windows 10, updating the BIOS, run tests/updated all drivers but with no lock. It's as if the dGPU is not present on this laptop.

 

Does anyone know what can cause this? Or have any potential solutions i can try?

 

Kind regards,

Robert

 

Reply
3 Replies
Highlighted
1 Copper

Re: PRECISION 5520 - Nvidia GPU not detected

I have this exact problem too. Just got a 5520 delivered. The screws underneath are stripped so I am worried this is a hardware fault. Nothing in Windows Device Manager or BIOS and Dell diagnostics shows passed but ‘video thermistor’ is N/A. 

 

What have you decided to do? I think mine will need to be returned. 

Reply
Highlighted
1 Copper

Re: PRECISION 5520 - Nvidia GPU not detected

Hi, I have the same computer and issue. Working fine for 5 months then one day had an issue with my main use software (Solidworks), tracing the issue led to the Quadro M1200 discrete GPU not being displayed in the device manager. Can view it when enabling 'view hidden devices' although the icon is opaque in contrast to the intel P630 integrated GPU icon.

Nvidia desktop manager not accessible.

Unable to update drivers, either form Dell or Nvidia 'compatible hardware not detected'

Checking status in device manager, 'error code 45 device not connected.

Have tried all kinds of fixes, no results yet.

Any advice will greatly appreciated.

Thanks in advance, Scott

Reply
Highlighted
1 Copper

Re: PRECISION 5520 - Nvidia GPU not detected

Recently had this same scenario happen but on a different Precision model (newer).  Turns out to be an actual hardware failure in my case and they system is now with Dell for depot support/repair.  Since it was the dedicated GPU, the integrated was still operational but NVidia GPU disappeared from OS and BIOS.

Running diagnostics did nothing as the system no longer knew it was present.  Might be a hardware issue as well considering pre-OS the GPU is not detected. 😠

Reply