sunbow
1 Copper

Precision 7720, TB16 dock & peak shift bug: TB16 trips off

Hi!

I discovered an interesting 'feature' of the TB-16 dock.

I have the latest bios and TB16 firmware & drivers.

Computer is powered by its own power supply, not by the dock. So there should be no reason for the dock to power the workstation.

The TB-16 is linked to 2 monitors: USB-C + DP, both also linked with USB ports, RJ45 ethernet cable is plugged also. Nothing is supposed to drain some significant power, both displays have their own PSU.

I'm using peak shift feature only to save some battery life: This computer is rarely used without external power and keeping the battery around 60% SOC is a good way to improve its life expectancy.

Now the problem in details: The TB16 shuts down when plugged-in each time that the computer's battery is above the "restore AC power if available charge falls below" level (60% in my case). It means that if the computer is powered by the battery only, plugged-in with its own power supply, the TB16 will shut down (over-current protection trips, power led turns off, and obviously TB cable led off). It resets as soon as it is unplugged from its power supply but only if I disconnect the USB-C cable before re-plugging the dock... guess why.

As soon as the computer reaches the 'Plugged-in not charging' level the problem is not occurring. I can even unplug the computer's power supply, using only the dock power... It takes the load and the battery doesn't charge, as it is supposed to with the peak shift settings.

If I don't use the computer's own PSU, the dock doesn't trips off, but when the computer is powered on, the dock starts charging the battery to 100%, ignoring the peak shift settings.

I spent me some time digging this out... This is obviously a bug with the TB16 firmware or the 1.13.0 Bios. Not related to the OS, as the behavior is the same with Windows or Ubuntu...

Just in case somebody has the same problem or can give a solution...

 

0 Kudos