mtsn
2 Bronze

Re: Precision 7730 -- brightness adjustment stops working in latest BIOS

I'm not sure if related, but i recently lost [fn]+[up] ability to change the brightness, as well.  BIOS 1.12.1 for me, and I'm on a 7530, not a 7730.  Linux for me, and doesn't work in live environments, either.

0 Kudos
DELL-Cares
Moderator
Moderator

Re: Precision 7730 -- brightness adjustment stops working in latest BIOS

Hi Mtsn,

 

Kindly share the system service tag through the private note, we will be glad to assist you further.


Social Media Support

#IWork4Dell
To help us troubleshoot, click our Dell-Cares name and send us a private message with your Dell PC or Monitor Service Tag number

0 Kudos
_Artur_
2 Bronze

Re: Precision 7730 -- brightness adjustment stops working in latest BIOS

Hi,

same problem: P7730 with UHD screen, GPU internal Intel 630, no discrete graphic card. Both 1.11 an 1.12 BIOS versions break brightness control with Fn+Up/Down. I reverted BIOS to version 1.10 and shortcuts work again.

My previous post has been removed, I hope this one stays.

0 Kudos
bjohnso2
2 Bronze

Re: Precision 7730 -- brightness adjustment stops working in latest BIOS

I have BIOS 1.12.1 and I am still not able to adjust the screen brightness on my 7730.  I have verified my drivers and they are all up to date.  I have the Quatro 5200 video card and it is the only active card since I have switchable video cards disabled in the BIOS.  Is there a fix for this?

0 Kudos
Woter1
2 Bronze

Re: Precision 7730 -- brightness adjustment stops working in latest BIOS

I too have a 7730 with the FN+ brightness issue.

The device is running Windows 10, Enterprise 1909.

The BIOS version is 1.12.1, released 09/12/2019.

I cannot control the brightness from within Windows.

@DELL, when may be expect a fix?

TIA

0 Kudos
_Artur_
2 Bronze

Re: Precision 7730 -- brightness adjustment stops working in latest BIOS

Looks like these bugs are universal: Windows 10 Enterprise, Windows 10 Pro, Ubuntu 18.04 LTS, Debian 11 (mine) - whether system is certified or not (Windows 10 NOT certified??). If shortcuts work in old Linux system, like Ubuntu 16.04, then in old enough Windows they would work too, I suppose.

The errors wrote in /var/log/syslog after using Fn+Up/Down keys were similar to already mentioned here:
ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.PEG0.NHDA], AE_NOT_FOUND (20190816/psargs-330)
ACPI Error: Aborting method \NEVT due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
ACPI Error: Aborting method \_SB.PCI0.LPCB.ECDV._Q66 due to previous error (AE_NOT_FOUND) (20190816/psparse-529)

About sleep: I didn't tried suspend shortcut, I set power key action to suspend instead. As long as I had 1.12 BIOS version laptop sometimes didn't wake up from sleep. It was difficult to find a reason, why just sometimes. AFAIR suspend/wake up worked fine in 1.11 (aside of broken brightness shortcut). After BIOS downgrade do 1.10 all functions work fine again.

Dell BIOS is like a wine: the older the better

mifalek
2 Bronze

Re: Precision 7730 -- brightness adjustment stops working in latest BIOS

My Precision 7530 has recently lost possibility to adjust screen brightness. Very annoying when one wants to work in the evening time. My BIOS ver is 1.12.1

0 Kudos
_Artur_
2 Bronze

Re: Precision 7730 -- brightness adjustment stops working in latest BIOS

I installed BIOS version 1.12.1, then tried Ubuntu 16.04, Ubuntu 18.04, Debian 11 - same error everywhere:

dmidecode returns:
BIOS Information
	Vendor: Dell Inc.
	Version: 1.12.1
	Release Date: 11/11/2019

Executing "tail -f /var/log/syslog", then Fn+Down followed by Fn+Up, kernel wrote below messages.

Ubuntu 16.04
uname -r
4.15.0-45-generic
Mar 30 05:59:29 ubuntu kernel: [  107.770168] ACPI Error: [\_SB_.PCI0.PEG0.NHDA] Namespace lookup failure, AE_NOT_FOUND (20170831/psargs-364)
Mar 30 05:59:29 ubuntu kernel: [  107.770176] 
Mar 30 05:59:29 ubuntu kernel: [  107.770176] Initialized Local Variables for Method [NEVT]:
Mar 30 05:59:29 ubuntu kernel: [  107.770177]   Local0: 00000000fd77df17 <Obj>           Integer 0000000000000080
Mar 30 05:59:29 ubuntu kernel: [  107.770180]   Local1: 000000000074939e <Obj>           Integer 0000000000000000
Mar 30 05:59:29 ubuntu kernel: [  107.770183]   Local2: 00000000dc62fcc4 <Obj>           Integer 0000000000000080
Mar 30 05:59:29 ubuntu kernel: [  107.770186] No Arguments are initialized for method [NEVT]
Mar 30 05:59:29 ubuntu kernel: [  107.770187] ACPI Error: Method parse/execution failed \NEVT, AE_NOT_FOUND (20170831/psparse-550)
Mar 30 05:59:29 ubuntu kernel: [  107.770192] ACPI Error: Method parse/execution failed \_SB.PCI0.LPCB.ECDV._Q66, AE_NOT_FOUND (20170831/psparse-550)
Mar 30 05:59:33 ubuntu kernel: [  112.436257] ACPI Error: [\_SB_.PCI0.PEG0.NHDA] Namespace lookup failure, AE_NOT_FOUND (20170831/psargs-364)
Mar 30 05:59:33 ubuntu kernel: [  112.436283] 
Mar 30 05:59:33 ubuntu kernel: [  112.436283] Initialized Local Variables for Method [NEVT]:
Mar 30 05:59:33 ubuntu kernel: [  112.436286]   Local0: 0000000059fc3298 <Obj>           Integer 0000000000000080
Mar 30 05:59:33 ubuntu kernel: [  112.436299]   Local1: 00000000d9b601e8 <Obj>           Integer 0000000000000000
Mar 30 05:59:33 ubuntu kernel: [  112.436308]   Local2: 00000000614c7224 <Obj>           Integer 0000000000000080
Mar 30 05:59:33 ubuntu kernel: [  112.436320] No Arguments are initialized for method [NEVT]
Mar 30 05:59:33 ubuntu kernel: [  112.436325] ACPI Error: Method parse/execution failed \NEVT, AE_NOT_FOUND (20170831/psparse-550)
Mar 30 05:59:33 ubuntu kernel: [  112.436343] ACPI Error: Method parse/execution failed \_SB.PCI0.LPCB.ECDV._Q66, AE_NOT_FOUND (20170831/psparse-550)


Ubuntu 18.04
uname -r
5.3.0-28-generic
Mar 30 06:09:45 ubuntu kernel: [  256.690488] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.PEG0.NHDA], AE_NOT_FOUND (20190703/psargs-330)
Mar 30 06:09:45 ubuntu kernel: [  256.690511] 
Mar 30 06:09:45 ubuntu kernel: [  256.690511] Initialized Local Variables for Method [NEVT]:
Mar 30 06:09:45 ubuntu kernel: [  256.690514]   Local0: 000000009fe66624 <Obj>           Integer 0000000000000080
Mar 30 06:09:45 ubuntu kernel: [  256.690524]   Local1: 0000000053e7b80b <Obj>           Integer 0000000000000000
Mar 30 06:09:45 ubuntu kernel: [  256.690530]   Local2: 000000005a4a8227 <Obj>           Integer 0000000000000080
Mar 30 06:09:45 ubuntu kernel: [  256.690538] No Arguments are initialized for method [NEVT]
Mar 30 06:09:45 ubuntu kernel: [  256.690543] ACPI Error: Aborting method \NEVT due to previous error (AE_NOT_FOUND) (20190703/psparse-531)
Mar 30 06:09:45 ubuntu kernel: [  256.690557] ACPI Error: Aborting method \_SB.PCI0.LPCB.ECDV._Q66 due to previous error (AE_NOT_FOUND) (20190703/psparse-531)
Mar 30 06:09:47 ubuntu kernel: [  258.921081] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.PEG0.NHDA], AE_NOT_FOUND (20190703/psargs-330)
Mar 30 06:09:47 ubuntu kernel: [  258.921104] 
Mar 30 06:09:47 ubuntu kernel: [  258.921104] Initialized Local Variables for Method [NEVT]:
Mar 30 06:09:47 ubuntu kernel: [  258.921107]   Local0: 00000000a067b9cb <Obj>           Integer 0000000000000080
Mar 30 06:09:47 ubuntu kernel: [  258.921117]   Local1: 00000000ebee75e9 <Obj>           Integer 0000000000000000
Mar 30 06:09:47 ubuntu kernel: [  258.921123]   Local2: 0000000053e7b80b <Obj>           Integer 0000000000000080
Mar 30 06:09:47 ubuntu kernel: [  258.921131] No Arguments are initialized for method [NEVT]
Mar 30 06:09:47 ubuntu kernel: [  258.921136] ACPI Error: Aborting method \NEVT due to previous error (AE_NOT_FOUND) (20190703/psparse-531)
Mar 30 06:09:47 ubuntu kernel: [  258.921150] ACPI Error: Aborting method \_SB.PCI0.LPCB.ECDV._Q66 due to previous error (AE_NOT_FOUND) (20190703/psparse-531)


Debian 11
uname -r
5.4.0-4-amd64
Mar 30 08:20:04 P7730 kernel: [  279.116144] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.PEG0.NHDA], AE_NOT_FOUND (20190816/psargs-330)
Mar 30 08:20:04 P7730 kernel: [  279.116149] ACPI Error: Aborting method \NEVT due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Mar 30 08:20:04 P7730 kernel: [  279.116154] ACPI Error: Aborting method \_SB.PCI0.LPCB.ECDV._Q66 due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Mar 30 08:20:04 P7730 kernel: [  279.120686] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.PEG0.NHDA], AE_NOT_FOUND (20190816/psargs-330)
Mar 30 08:20:04 P7730 kernel: [  279.120690] ACPI Error: Aborting method \NEVT due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Mar 30 08:20:04 P7730 kernel: [  279.120693] ACPI Error: Aborting method \_SB.PCI0.LPCB.ECDV._Q66 due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Mar 30 08:20:07 P7730 kernel: [  281.828403] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.PEG0.NHDA], AE_NOT_FOUND (20190816/psargs-330)
Mar 30 08:20:07 P7730 kernel: [  281.828408] ACPI Error: Aborting method \NEVT due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Mar 30 08:20:07 P7730 kernel: [  281.828412] ACPI Error: Aborting method \_SB.PCI0.LPCB.ECDV._Q66 due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Mar 30 08:20:07 P7730 kernel: [  281.833088] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.PEG0.NHDA], AE_NOT_FOUND (20190816/psargs-330)
Mar 30 08:20:07 P7730 kernel: [  281.833093] ACPI Error: Aborting method \NEVT due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Mar 30 08:20:07 P7730 kernel: [  281.833096] ACPI Error: Aborting method \_SB.PCI0.LPCB.ECDV._Q66 due to previous error (AE_NOT_FOUND) (20190816/psparse-529)

 

0 Kudos
mtsn
2 Bronze

Re: Precision 7730 -- brightness adjustment stops working in latest BIOS

yeah, we're all getting it.  I've tried Windows, the image that my laptop came with, and the newest Ubuntu, all the same.  Also brightness and sleep issues.  The only fix it to revert back to BIOS/EFI firmware 1.10, and ignore messages to upgrade to 1.12 (or 1.11).  We'll see if Dell steps forward and provides a 1.13 firmware.

0 Kudos
Jeffonion
2 Bronze

Re: Precision 7730 -- brightness adjustment stops working in latest BIOS

I am having save issue when disable switch graphic card. If I use both graphic cards it is fine, but disable intel graphic card and only using nvidia P5200 , the display is always in maximum brightness.

0 Kudos