2 Bronze

Throttle problem Precision M6400

I am having a dell precision m6400 with non-genuine ac adapter of 130W which is enough for for running without battery. the issue i get is my cpu stuck at 1.2Ghz. my cpu is dual core p8400 2.26Ghz. i fixed this issue on windows by using software named throttlestop yes it fixed it and worked perfect!. but i have my working on linux, virtualbox is too slow for me. so i installed debian. it also throttles cpu at 1.2Ghz. and i cannot find a fix for it in debian. i even tried speedstep to turn off but that is not a issue. i find this as a solution  after searching enough community based posts. but the problem is i cannot find proper register for my cpu. this command :

sudo rdmsr -a -d 0x1FC 

 0x1FC register is not for my cpu. i cannot even find this online. so im stuck at 1.2Ghz. any solution to fix this in linux would be great. Note: i cannot buy genuine charger in my country because its expensive enough.

0 Kudos
1 Reply
2 Bronze

Re: Throttle problem Precision M6400

Always leave SpeedStep enabled. MSR 0x1FC is only for the newer Core i CPUs. For Core 2 Duo, you need to set MSR 0x1A0 bit[17] to 0.

The proper way to do this is to first Rdmsr to find out the current value, modify it and then write back the result to the same register. If the Rdmsr command is reading 64 bits in Linux you would do this.

value = Rdmsr 0x1A0

value = value & 0xFFFFFFFFFFFDFFFF

Wrmsr 0x1A0, value

Hopefully you can figure out the proper syntax and make this work.

0 Kudos