Last reply by 05-24-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

E514dw print function will not work; job spools but never prints

Dell E514dw print function just stopped working out of the blue.  This happened several months ago.

When a document is printed from the PC (Win10), it spools, disappears from the queue, and the LCD on the printer shows "Receiving Data".  BUT IT NEVER PRINTS.  It hangs there.  I have to completely shut down the printer to clear the memory.

I uninstalled and reinstalled the driver MULTIPLE times.  I've stopped and started the Spooler service.  I've started and restarted too many times to count.  I've done all the usual tricks.

I don't think it's an operating system or driver issue.  I think it's a printer issue.  I can't even print a test page from the onboard menu on the printer.

Any thoughts or clues?  I really appreciate it!

Replies (13)
Community Manager

I think it sounds like an issue with the printer (since test page from the menu doesn't work), but have you tried doing the test page after a fresh power down/on etc? Also, how is your computer connected to the printer?

Best regards,



Exact the same issue. Tried multiple different ways

Reinstall driver, restart computer, reset printer, power off and on, nothing works

2 Bronze
2 Bronze

I just tried a fresh power down and test print... Unfortunately the printer just hangs on "Test Print... Printing", but nothing further happens.

Printer is connected via USB cable.




exact same problem i experienced.  tried uninstall reinstalling driver.


Test page without USB connection or WITH cable would not print.

Often says "Receiving Data" and nothing happens


I have the exact same problem with E514DW. The copier works but the printer is having problem. Test page stuck in Printing and anything else stuck in Receiving Data.

Community Manager

Hi Kevin, 

Thanks for the updates, can you let me know if the printer is still in Warranty? Unfortunately it sounds like this might be hardware related, but I will also check on my side, just to make sure I am not missing anything. 

Best regards,


9 Palladium


Does the spooled print job print if you restart your computer?

Did you check your virus program and firewall?



Welcome to Dell Community!

#DellWorld 2012
#DellWorld 2015
#Dell EMC World 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

This is a Dell User Forum. I am a Dell user, just like you are.
2 Bronze
2 Bronze

Were you able to find a resolution? Experiencing the exact same issues described, exact same model of Printer.


Cant even print a configuration page. Just sits at "Receiving data". I've let it sit for 20+minutes. Rebooted and tried again. Same issue.


Thank you.


exact same issue i have and i see no resolution here or searching it online. any any help?

Latest Solutions
Top Contributor