Anonymous
6 Gallium

Freezing Dell2145cn Printer - 'Initializing'

Hello!

When I switch my Dell printer 2145cn on it freezes displaying message 'initializing'. When I press copy, fax or any button nothing happens. I thought that the problem would be fixed by switching it off for a few minutes. I switched it off and unplugged for a couple of minutes.. Turned it on and it started, some usual humming and calibrating.. And then again – it froze, no response to pressing buttons or removing trays (usually it would change led lights).

Printer is connected to a router – I do not use USB cable as I use it as a network printer. There are 2 computers connected to the same router (Windows Vista). When I tried to print from those computers I was getting the same message from dell tray window – that printer couldn’t be contacted. (This setup was working for the last few months with no problems)

I disconnected printer from the network unplugging it completely from the router and restarted it – it worked, no freezing. I could check settings on it and copy few pages. Wow! I also restarted computers. Connected the UTP to printer and tried to print – printer froze as soon as a cable was connected.

I searched internet forums and found someone was suggesting that it was faulty printer network card..

 The funny thing is that if I go to network (on any computer) I can see printer there and I can even check settings. I was wondering if the problem is on computers side... But both computers at the same time? And why printer is behaving this way? If something was wrong with computer(s) printer wouldn’t freeze..?

Could someone help me?

Regards

Tags (2)
0 Kudos