Highlighted
Jose_Luis_OV
2 Bronze

Error on Topology Service after upgrade Prosphere 1.7 to 2.0.1

Hi,

After a success upgrade of vApp of Prosphere 2.0.1, when I re-run discovery jobs always finish with status FAIL.

I do Power OFF and Power ON process using vCenter, nothing change.

Here the message that I got on Window Log after execute any Discovery Job (Arrays, Hosts & Switchs)

Timed out while waiting for Topology Service to process data

No Response From Topology Service

I use this URL to look for issues on services but all the services on vApp are Ok,

https://<prosphereapp>/cgi-bin/mon.cgi

srmagmserver"Maps Service"2.0.0.0.0.243-30s+30s
srmdiscovery-restserver"Discovery REST Service"2.0.0.0.0.124-56s+4s
srmhistservice"Historical Service"2.0.1.0.0.251-32s+28s
srmiil-localtransformer"Topology Transformer Service"2.0.0.0.0.13-51s+9s
srmiil-restserver"Topology Service"2.0.0.0.0.13-9s+51s

Can someone help me to fix this issue?, there are any way to test Topology service by command line?

Regards.

Jose Luis

Tags (2)
6 Replies
gawanb
1 Copper

Re: Error on Topology Service after upgrade Prosphere 1.7 to 2.0.1

Jose,

You can run the command "service iil-restserver status" on the SRM appliance to check the status of the service.  Pretty sure it must be running.  you can try service iil-restserver stop and then service iil-restserver start.  And then run the discovery job again.  It may be more than iil-restserver.  But give it a try.

Also, was the upgrade successful or were there any issues encountered. ?  If there is any SR opened, let me know and I can help you on a webex.

- Brijesh

0 Kudos
Jose_Luis_OV
2 Bronze

Re: Error on Topology Service after upgrade Prosphere 1.7 to 2.0.1

Hi ganwanb,

I restart iil-restserver service, but nothing change. I have an issue when I try to upgrade Discovery Engine VM. I wonder if Topology Service is related to Discovery engine.

May be this is the cause of the problem.

Unfortunately I can not currently generate a SR.

Regards

0 Kudos
gawanb
1 Copper

Re: Error on Topology Service after upgrade Prosphere 1.7 to 2.0.1

Hello Jose,

That is definitely an issue.  We need discovery engine up and running for the discovery job to complete.  I can help you with the upgrade issue on a webex.  I would need an SR for that.  If you cannot open an SR, then I can open one for you.  Can you email me the site ID for which this issue is and also your contact information.  My email ID is brijesh.gawande@emc.com.

Thanks.

- Brijesh

Jose_Luis_OV
2 Bronze

Re: Error on Topology Service after upgrade Prosphere 1.7 to 2.0.1

Hi Brijesh,

I will email you with the requested information. If is possible please help me to open a new SR.

Regards

Jose Luis

0 Kudos
gawanb
1 Copper

Re: Error on Topology Service after upgrade Prosphere 1.7 to 2.0.1

Hi Jose,

As discussed over email, I will open a new SR and we will work on a webex tomorrow 7/30/2013

- Brijesh

0 Kudos
vvsivasai
1 Copper

Re: Error on Topology Service after upgrade Prosphere 1.7 to 2.0.1

Hi

I Am also facing same issue all jobs are failing can any body pls help on this..

Thanks

Sivasai

vvsivasai.padala.2@volvocars.com

0 Kudos