Highlighted
umichklewis
4 Tellurium

Prosphere not collecting Symmetrix Performance Data from SPA

Jump to solution

I'm setting up Prosphere 2.0.1.0 for the first time.  I've worked through the Deployment guide step-by-step, but I'm stuck getting any performance data into the Historical Database.  I have my VMAX discovered properly, but all performance data collection is failing.  I'm running SMAS 7.3.0.6 and have no trouble accessing SMC and SPA.  But I see these errors in the logs:

Any ideas where to look next?

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
ConorLawlor
3 Argentium

Re: Prosphere not collecting Symmetrix Performance Data from SPA

Jump to solution

Hi Karl,

https://support.emc.com/docu47111_ProSphere-2.0-Security-Configuration-Guide.pdf?language=en_US page 15 table with all default users and passwords used in ProSphere

Regards

Conor

4 Replies
ConorLawlor
3 Argentium

Re: Prosphere not collecting Symmetrix Performance Data from SPA

Jump to solution

Hi Karl,


The 2.0 deployment guide gives steps on "Integrate ProSphere with Unisphere for VMAX" the section "Integrate ProSphere with SMAS" was removed so for you to get this information review the 1.7 depolyment guide pages 77 to 82 has all the required steps please double check to ensure they are correct https://support.emc.com/docu46156_ProSphere-1.7.0.1-Deployment-Guide.pdf?language=en_US

Ensure the following collections are enabled in SPA otherwise ProSphere will not populate the two graphs in question

  • To collect Array FE Directors - % Busy data for a Symmetrix array, select the Base and Diagnostic collections for the array in the Administration -> Data Collection Registration dialog box of SPA.
  • In addition, for the Array FE Directors - % Busy metric chart, select FE Director” -> “% Busy in the Administration - Metric Management dialog box. This metric is enabled by default as part of the SPA installation.


ProSphere gathers the list of installed SMAS instances from Solutions Enabler/SMI-S Provider. One can verify the registered SMAS instances (look for 'SMC' and 'SPA') from the SMI-S Provider host by running the 'symcfg list -applications' command ensure the correct instance of SMC/SPA are listed.

Review the following KB solutions for troubleshooting tips and logs etc that will help to pinpoint the issue

https://support.emc.com/kb/83946
https://support.emc.com/kb/15777
https://support.emc.com/kb/78741
https://support.emc.com/kb/92134

If you are still having issues after performing the above steps please open an SR with Support. Attaching the symcfg list -applications output and the prosphere logs collected from the Admin -> System -> Manage logs UI

Just to note: ProSphere will not discover VMAX performance statistics unless the end-to-end topology is discovered and PDC turned on from a host in the path for the graphs which details are not taken from SPA.

Within ProSphere at least one switch, one host and along with the array must be must be successfully discovered and in the performance path for performance data to be collected .


Regards

Conor

umichklewis
4 Tellurium

Re: Prosphere not collecting Symmetrix Performance Data from SPA

Jump to solution

After struggling with getting the KB articles opened, I can't figure out how to resolve Step 7.

How do I log into the Prosphere VM (user name?  password?) to check these things?

Thanks!

0 Kudos
ConorLawlor
3 Argentium

Re: Prosphere not collecting Symmetrix Performance Data from SPA

Jump to solution

Hi Karl,

https://support.emc.com/docu47111_ProSphere-2.0-Security-Configuration-Guide.pdf?language=en_US page 15 table with all default users and passwords used in ProSphere

Regards

Conor

umichklewis
4 Tellurium

Re: Prosphere not collecting Symmetrix Performance Data from SPA

Jump to solution

Thanks!  That's good me logged in.  I will continue troubleshooting and report back.

0 Kudos