Highlighted
rmccarthy24
1 Copper

Dell DataSafe Online help

Ok I wanted to see if i could back my computer up using Dell's DataSafe online so i started the program on my XPS M1530 and I got this message

"Invalid package ID

Make sure your connected to the internet and try again."

I clicked on the help link provided and it brought my browser up and I got this message

"The site's security certificate is not trusted!

You attempted to reach www.delldatasafe.com, but the server presented a certificate issued by an entity that is not trusted by your computer's operating system. This may mean that the server has generated its own security credentials, which Google Chrome cannot rely on for identity information, or an attacker may be trying to intercept your communications. You should not proceed, especially if you have never seen this warning before for this site."

Um I know what the message means but i just don't know what to do haha, and for some reason at this time the live chat is closed so I can talk to anyone.

So does anyone know what to do?

Tags (1)
0 Kudos
1 Reply
Jeff Hoffman
4 Tellurium

Re: Dell DataSafe Online help

I got pretty much the same message the first time I tried DataSafe with IE8. I decided to try it anyway. It worked fine and I haven't seen the message since. I don't know the explanation for this but everything has been fine for me.

Jeff

XPS 8100 i7-860(8MB Cache, 2.8GHz), 8GB Dual Channel DDR3 SDRAM @ 1333MHz, 750GB SATA 3.0GB/s 16MB Cache, nVidia GeForce GTS2401GB GDDR3, Dell ST2310 Full HD Widescreen Monitor, AverMedia G2 Combo hybrid TV Tuner, dual 16x DVD+/- RW dbl layer, Microsoft LifeCam Cinema HD, Running Windows 7 Home Premium, 64 bit. 

If your question is answered here on the forums; PLEASE post back! It may help another user.              

0 Kudos