Highlighted
Not applicable

5100MP, not detecting any input signal

I bought two DELL 5100MP about four years ago (let's call them P1 and P2), and apart from replacing a bulb on one they were working well for my home theatre - BluRay DVD (HDMI) and laptop (VGA) projection.

One projector (P1) is okay. The other projector (P2) recently does not detect input signal - neither from Bluray player (HDMI) or from laptop (VGA) input. It will display a white screen with HDMI icon or VGA icon in bottom right depending on what I manually set it to detect, but it also says 'No signal" in middle of white, or blue projectred screen (with Dell icon in middle). Bulb is obviously working okay. It does not ever display the laptop desktop or the DVD images. I also swapped out the color wheel for a spare I bought in case it might help but it did not.

Also, the menu no longer shows option of "IMAGE SETTINGS" at top - it is dimmed out - as are the next three options: computer source, video source, PIP settings).

See photos below.

The next item, Network Settings is displayed in the menu and below that Management - so I can use Management to get into source - autodetect or manual.

I tried "factory reset" using the manual menu buttons on the projector top - which still work, as remote doesn't - the remote control also now does not work with it - it does not bring up any menu on the projected screen image. The remote works normally with P1. I have opened the projector up many times and checked the remote's wire connections inside the projector and they seem tight and okay.

Maybe I loosened something but I don't know what.


P1 works fine with BluRay/DVD and with laptop.

The remote is not important, but I need P2 to detect a signal. It's a great projector for Bluray - does anyone else use it for this? Would a dedicated 1080p 16 x 9 projector show a noticeable difference 9another topic!).

is this signal loss detection a common problem? Is there a simple solution? Could it be fixed? Or is it a hopeless hardware problem??

Thanks!

JT

0 Kudos
Reply
1 Reply
Highlighted
Not applicable

Nice product!

0 Kudos
Reply