poet_imp
2 Bronze

CLI Command to enable access to a specific bookmark

Jump to solution

I am trying to script a tape backup from a CDP copy of a database. I have already scripted the quiese and bookmark process on the database host. Now I need to access that bookmark on another host and can not for the life of me get the right syntax. I can access "latest" image but I can enable_image_access the bookmarked image directly.

Any assistance would bemuch appreciated.

Labels (1)
1 Solution

Accepted Solutions
JamesBEMC
3 Argentum

Re: CLI Command to enable access to a specific bookmark

Jump to solution

So, typically it would be

enable_image_access group="my group" image="my 10am image"

Is this what you are trying?

You can build the command interactively via the CLI.

James

View solution in original post

0 Kudos
14 Replies
JamesBEMC
3 Argentum

Re: CLI Command to enable access to a specific bookmark

Jump to solution

Hey there

We have a RP CLI document, which you probably looked at on Powerlink

http://powerlink.emc.com/km/live1/en_US/Offering_Technical/Technical_Documentation/300-009-433.pdf?

 Enable_image_access

Parameters

group=<group name>

copy=<copy name>

[image=<...> | latest | prev | next]

[time=HH:MM[:SS[:MICROS]] [DD/MM/YYYY]]

[image_type=all | bookmark | user_bookmark | system_bookmark] (Default: all)

[search_text=<...>]

[exact_text=yes | no] (Default: yes)

[scn=<integer>]

[max_search_range=<num>months | <num>weeks | <num>days | <num>hrs | <num>mins | <num>secs]

[access_mode=logged | virtual_with_roll | virtual_without_roll] (Default: logged)

So, an example would be

enable_image_access group="my group" image=latest image_type=all

Thanks

James.

0 Kudos
poet_imp
2 Bronze

Re: CLI Command to enable access to a specific bookmark

Jump to solution
This much I have working. The problem is that I do not want the "latest" bookmark. I want the one I named during the time the database was quiesed.
0 Kudos
JamesBEMC
3 Argentum

Re: CLI Command to enable access to a specific bookmark

Jump to solution

So, typically it would be

enable_image_access group="my group" image="my 10am image"

Is this what you are trying?

You can build the command interactively via the CLI.

James

View solution in original post

0 Kudos
poet_imp
2 Bronze

Re: CLI Command to enable access to a specific bookmark

Jump to solution
Color me pink... It was not obvious to me that the image parameter would accept a bookmark name. It makes perfect sense, though. I was trying to use the Image_type, search_text and exact_text parameters and they were simply not supplying any joy. Thank you!
0 Kudos
JamesBEMC
3 Argentum

Re: CLI Command to enable access to a specific bookmark

Jump to solution
Cool!
0 Kudos
achrom
2 Bronze

Re: CLI Command to enable access to a specific bookmark

Jump to solution

2018 RP 5 - to use specific bookmark  I have to use

image=search_image image_type=user_bookmark  search_text='my bookmark label'

with image='my bookmark label'  only -  I will get a syntax error

0 Kudos
Idan
DellEMC

Re: CLI Command to enable access to a specific bookmark

Jump to solution

Can you please provide the full command you're trying to run and the output ?

Granted you're providing the group and copy parameters, it should work.

Regards,

Idan


Idan Kentor
Tech Staff Engineering Technologist - Data Protection


idan.kentor@dell.com
@IdanKentor
0 Kudos
achrom
2 Bronze

Re: CLI Command to enable access to a specific bookmark

Jump to solution

enable_image_acces group=mytestgroup image=my_bookmark copy=mycopy access_mode=virtual_with_roll

Error: Invalid ‘image’ parameter (with “,’ and without)

If it will, I will get something like “your splitter does not support virtual access”

RP 5.1c gen 5, vmax20k (something like rcm 6.0.19)

I have to use parameters as I have provided (search, user, text) to get it working.

I have run it now having copy accessible, it fails on syntax.

BR

Andrzej

0 Kudos
Idan
DellEMC

Re: CLI Command to enable access to a specific bookmark

Jump to solution

Indeed you should have either ' or "" for the value of image.

And the error you're getting on virtual access, that is expected as the VMAX2 splitter supports only logged access. Virtual access is supported with VNX, VNXe and Unity splitters.

Hope that helps,

Idan


Idan Kentor
Tech Staff Engineering Technologist - Data Protection


idan.kentor@dell.com
@IdanKentor
0 Kudos