sasamir1
2 Iron

Recover Point simulator error

Jump to solution

Hi All,

Just managed to install Recover Point simulator, but when I launch IE8 browser and try to login to the appliance I receive the following error:

Unhandled event loop exception
java.lang.NullPointerException
I've uninstalled java numerous times but every time this error pops up. Would appreciate any suggestions or workaround for this.
regards,
Samir
Labels (1)
0 Kudos
1 Solution

Accepted Solutions
Gary_Archer
1 Nickel

Re: Recover Point simulator error

Jump to solution

That is normal as when you look under the VMware monitoring you'll see some LUNs that are not being fully protected by RP.  If you add those LUNs to a consistency group (such as MyESX2)  you will see that this warning will go away AND that each of the VMs are fully protected by RP.

Gary

0 Kudos
6 Replies
Gary_Archer
1 Nickel

Re: Recover Point simulator error

Jump to solution

Any chance you can send me a screen capture?  Also I'd suggest the following two things:

1) Try a different version of JRE -- the most current version is 23, but any of the double diget versions should work.

2) Try a different browser, I've used both IE 7/8 and Firefox (Mozilla) with no issues.

Regards

Gary

0 Kudos
sasamir1
2 Iron

Re: Recover Point simulator error

Jump to solution

Hi Gary,

I tried with different browsers still the same error. Following are java console messages:

===========================================================================================

Java Web Start 1.6.0_21
Using JRE version 1.6.0_21-b07 Java HotSpot(TM) Client VM
User home directory = C:\Documents and Settings\Sam
----------------------------------------------------
Starting workbench...
01/05 08:55:15 - javawsApplicationMain - ApplicationInitializer.login(): Starting login process...
01/05 08:55:23 - javawsApplicationMain - SystemModel.initConnection(): looking up: //192.168.221.128:1099/ManagementService
01/05 08:55:25 - javawsApplicationMain - SystemModel.initConnection(): success looking up: //192.168.221.128:1099/ManagementService

01/05 08:55:30 - javawsApplicationMain - SystemModel.openSession: checkUserPermission() failed, error is: Error: Permission denied.
!SESSION 2011-01-05 08:55:10.765 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_21
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments:  -consoleLog

!ENTRY com.kashya.recoverpoint 4 0 2011-01-05 08:55:30.906
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.NullPointerException
    at com.kashya.management.model.SystemModel.sendLoginEvent(SystemModel.java:3490)
    at com.kashya.management.rcp.dialogs.LoginDialog.doLogin(LoginDialog.java:471)
    at com.kashya.management.rcp.dialogs.LoginDialog.okPressed(LoginDialog.java:345)
    at org.eclipse.jface.dialogs.Dialog.buttonPressed(Dialog.java:472)
    at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:624)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:228)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3880)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3473)
    at org.eclipse.jface.window.Window.runEventLoop(Window.java:825)
    at org.eclipse.jface.window.Window.open(Window.java:801)
    at com.kashya.management.rcp.dialogs.LoginDialog.open(LoginDialog.java:118)
    at com.kashya.management.rcp.application.ApplicationInitializer.login(ApplicationInitializer.java:87)
    at com.kashya.management.rcp.application.ApplicationInitializer.<init>(ApplicationInitializer.java:60)
    at com.kashya.management.rcp.RecoverPointApplicationWorkbenchWindowAdvisor.preWindowOpen(RecoverPointApplicationWorkbenchWindowAdvisor.java:44)
    at org.eclipse.ui.internal.WorkbenchWindow.fireWindowOpening(WorkbenchWindow.java:1284)
    at org.eclipse.ui.internal.WorkbenchWindow.<init>(WorkbenchWindow.java:398)
    at org.eclipse.ui.internal.tweaklets.Workbench3xImplementation.createWorkbenchWindow(Workbench3xImplementation.java:31)
    at org.eclipse.ui.internal.Workbench.newWorkbenchWindow(Workbench.java:1731)
    at org.eclipse.ui.internal.Workbench.access$14(Workbench.java:1729)
    at org.eclipse.ui.internal.Workbench$19.runWithException(Workbench.java:1023)
    at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3855)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3476)
    at org.eclipse.ui.application.WorkbenchAdvisor.openWindows(WorkbenchAdvisor.java:803)
    at org.eclipse.ui.internal.Workbench$28.runWithException(Workbench.java:1384)
    at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
    at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:179)
    at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchronizer.java:150)
    at org.eclipse.swt.widgets.Display.syncExec(Display.java:4312)
    at org.eclipse.ui.internal.StartupThreading.runWithoutExceptions(StartupThreading.java:94)
    at org.eclipse.ui.internal.Workbench.init(Workbench.java:1379)
    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2335)
    at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)
    at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:493)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
    at com.kashya.management.rcp.RecoverPointApplication.start(RecoverPointApplication.java:48)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
    at org.eclipse.equinox.launcher.WebStartMain.basicRun(WebStartMain.java:79)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
    at org.eclipse.equinox.launcher.WebStartMain.main(WebStartMain.java:57)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.sun.javaws.Launcher.executeApplication(Unknown Source)
    at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
    at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
    at com.sun.javaws.Launcher.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)

==========================================================================================================

I've updated Java to 6 update 23 but still receive the same error. I'm unable to upload the screenshot as it doesnt allow JPEG or Bitmap images.But this is the error message

================================================

Unhandled event loop exception
java.lang.NullPointerException

================================================

Appreciate your help.

regards,

Samir

0 Kudos
Highlighted
Gary_Archer
1 Nickel

Re: Recover Point simulator error

Jump to solution

I assume you get the GUI login screen -- ensure you are using admin for the userid and admin for the password.

If that does not work try security-admin as the userid and security-admin for the password

From windows can you ping the IP of the VM (the same IP you got when you logged into the VM console using userid IP password IP.

Second you can send me the screencapture directly to my email (gary.archer@emc.com) and I'll see what I can do from there.

Gary

sasamir1
2 Iron

Re: Recover Point simulator error

Jump to solution

Thanks Gary for the help, its working now.

Only issue is Storage have a exclamation mark warning" VM not protected ", any suggestions?

regards,

Samir

0 Kudos
Gary_Archer
1 Nickel

Re: Recover Point simulator error

Jump to solution

That is normal as when you look under the VMware monitoring you'll see some LUNs that are not being fully protected by RP.  If you add those LUNs to a consistency group (such as MyESX2)  you will see that this warning will go away AND that each of the VMs are fully protected by RP.

Gary

0 Kudos
sasamir1
2 Iron

Re: Recover Point simulator error

Jump to solution

Thanks Gary.

0 Kudos