Highlighted
tanr1
1 Nickel

How to mount /dev/scinia at boot

Jump to solution

I added the a line in /etc/fstab to mount the file system in /dev/scinia1 at boot but Linux complains the device is not available.  The sds.service hasn't started yet.  How can I get my file system in /dev/scinia1 mounted at boot after sds.service has started?

0 Kudos
3 Replies

Re: How to mount /dev/scinia at boot

Jump to solution

Hi,

Few Qs:

1. Did you mean that the SDC service did not come up? SDS has nothing to do with the mount issue on /dev/scinia1 that you are describing.

2. Which OS + File System are you using?

3. Is there some journal operation taking place, hence the device may not be available yet? perhaps consider adding a sleep for this mount..

4. Devices may change name in Linux after boot, so I would recommend to perform the mount by device ID and not by name:

You can find the /dev/scinia1 in /dev/disk/by-id

Use the full path '/dev/disk/by-id/[ID]' for your mount.

0 Kudos
alexkh
2 Iron

Re: How to mount /dev/scinia at boot

Jump to solution

Please consider to add _netdev to mounting options.

ScaleIO needs network to operate and the devices won't be ready until network was loaded.

Example:

/dev/scinia1     /mountpoint        ext4    defaults,auto,_netdev 0 0

tanr1
1 Nickel

Re: How to mount /dev/scinia at boot

Jump to solution

The _netdev option does it.  Thanks!