Highlighted
wyee-sgSG_
1 Nickel

can SAM Dynamic Model v9.2 work with latest java version 1.8 or 1.9?

Jump to solution

Hello, it's been a long while since I've installed and worked on our EMC SMARTS Dynamic Model v9.2 systems which are running using java version 1.6.0_37.  Since all java versions from 1.7 and below are going End of Service Life and have security vulnerabilities, we need to update the systems to the latest java versions.  My question is, will SAM Dynamic Model v9.2 work okay if java is updated to say v1.7 or later? Anyone gone through this and can share their experiences?

Labels (2)
0 Kudos
1 Solution

Accepted Solutions
ron-miller
1 Copper

Re: can SAM Dynamic Model v9.2 work with latest java version 1.8 or 1.9?

Jump to solution

Wyee-sgSG,

Upgrading the version of java that is included inside of Smarts is not recommend as the libraries that are compiled in the java code may not be forward compatible.

Ron Miller

Advisor, Enterprise Tech Services

Dell EMC | Services

0 Kudos
6 Replies
wyee-sgSG_
1 Nickel

Re: can SAM Dynamic Model v9.2 work with latest java version 1.8 or 1.9?

Jump to solution

Correction to previous post... I meant to say if it would work if we updated to java versions 1.8 or 1.9... (not 1.7).

0 Kudos
SeanPopham
1 Nickel

Re: can SAM Dynamic Model v9.2 work with latest java version 1.8 or 1.9?

Jump to solution

Wyee-sgSG,

Thank you for contacting Dell EMC Technical Support Forum.

Please review KB 303306 : ESA-2015-005: EMC Service Assurance Suite Security Update for Multiple Oracle Java and Apache Tomcat Vulnerabilities https://support.emc.com/kb/303306

Please let me know if this does not answer your question.

Kind Regards,

Sean

0 Kudos
wyee-sgSG_
1 Nickel

Re: can SAM Dynamic Model v9.2 work with latest java version 1.8 or 1.9?

Jump to solution

Thanks for pointing to and sharing that article Sean.  However that article says the upgrade to java 1.8 was implemented in SAM v9.4 and we are on v9.2.  It mentions to upgrade to the latest v9.4 but then that would open us up to a whole other concerns of our custom code compatibility between v9.2 and v9.4.

I was wondering if we just replace the java 1.6 in our current SAM Dynamic Model v9.2 package with java 1.8 if it would still work unscathed.

0 Kudos
SeanPopham
1 Nickel

Re: can SAM Dynamic Model v9.2 work with latest java version 1.8 or 1.9?

Jump to solution

Wyee-sgSG,

Thank you for your quick response.  We will need to research and confirm this and will provide an update on Monday Jan 15th.

Kind Regards,


Sean.

0 Kudos
ron-miller
1 Copper

Re: can SAM Dynamic Model v9.2 work with latest java version 1.8 or 1.9?

Jump to solution

Wyee-sgSG,

Upgrading the version of java that is included inside of Smarts is not recommend as the libraries that are compiled in the java code may not be forward compatible.

Ron Miller

Advisor, Enterprise Tech Services

Dell EMC | Services

0 Kudos
SeanPopham
1 Nickel

Re: can SAM Dynamic Model v9.2 work with latest java version 1.8 or 1.9?

Jump to solution

Wyee-sgSG,

Did we answer your question.

Please let me know.

Kind Regards,


Sean Popham

0 Kudos