Highlighted
cgrvy
1 Nickel

Adapter 4 with vROPS to VMAX

Jump to solution

Hi,

I'm trying to get the EMC adapter (version 4.0.168071) working with a VMAX in our environment. When I try to add a VMAX to the adapter, I give it:

A name

Management IP address with port :5988

Array ID

Set connection type of VMAX

Don't add in a license (as this is a trial)

Enter the valid credentials.

I get the error:

"Unable to establish a valid connection to the target system. error connecting to array."

When I change the port ID to :5989 I get the error:

"Unable to establish a valid connection to the target system. Wait for response of task 'Test connection' is timed out for collector "vRealize Operations Manager Collector vRealize Cluster node'".

Anyone have a similar issue and manage to fix it?

Labels (1)
0 Kudos
5 Replies
Zack_Z
1 Nickel

Re: Adapter 4 with vROPS to VMAX

Jump to solution

Hi cgrvy,

     Are you on VMAX2 or VMAX3? When adding the adapter in ESA, is the ip address you entered for "solutions enabler" or "VMAX unisphere"?

0 Kudos
WorldPolice
2 Iron

Re: Adapter 4 with vROPS to VMAX

Jump to solution

As Zack notes you are attempting to use an SMI-S Provider when ESA 4.0 requires the Unisphere REST API. You need to put in the Unisphere for VMAX IP address.  Check out this blog post for detail:  ESA 4.0 and Unisphere for VMAX REST API |

0 Kudos
cgrvy
1 Nickel

Re: Adapter 4 with vROPS to VMAX

Jump to solution

Hi,

I've been trying to use version 4 of the plugin - but I think that it is not supported with the versions of VMAX(s) that I am using:

SymmID       Attachment  Model     Version  Size (MB)  Devices   Devices

0001234567899 Local       VMAX-1    5876      120320        11      5836

0009876543211 Local       VMAX100K  5977      207872        13       181

0001212121212 Remote      VMAX20K   5876      120320         0      3018

I'm looking at the notes and it looks like plugin version 3.3 is the latest supported version for my environment?

0 Kudos
WorldPolice
2 Iron

Re: Adapter 4 with vROPS to VMAX

Jump to solution

ESA 4.0 no longer supports VMAX2 which would be your VMAX-1 and VMAX20K arrays.   It will support, however, the VMAX100K which is a VMAX3.  The last version of ESA to support VMAX2 and VMAX3 is version 3.5.  Just a reminder that ESA 3.5 uses SMI-S and requires that all arrays are seen as Local, not Remote.

0 Kudos
cgrvy
1 Nickel

Re: Adapter 4 with vROPS to VMAX

Jump to solution

That is great Drew - thanks a million!

0 Kudos