Highlighted

AHCI BIOS not present/No device found

I here have a 2008/2009 Optiplex 760. 2gb RAM, Dual core Pentium @ 2.50ghz. WD Blue 500gb HDD.

Every time I try to start it up, this is what it says:

No device found

AHCI BIOS not installed

Alert! Rear fan failure.

Strike the F1 key to continue, F2 to run the setup utility

 Press F5 to run onboard diagnostics

I get that the rear fan is failing, and in that case, probably the power supply.

Pressing F1 to continue leads to:

No boot device available -

strike F1 to retry boot, F2 for setup utility

Press F5 to run onboard diagnostics

I've tweaked the bios numerous times, but nothing seems to work. I've tried to use another HDD, but same thing. Everything is fine in the onboard diagnostics.

I originally found this PC in a tech classroom. I put it back together and took it. The CMOS battery (along with its holder) was ripped off. Just replaced it tonight, after I was told that the CMOS would fix the AHCI BIOS error. Nope. I've tried rewiring the HDD/ DVD ROM cables a ton of times. I have two HDDs installed at the moment, but the bios doesn't seem to recognize either of them, even when going into boot manager. I believe the current os installed on the WD drive is Vista, but the OS sticker was partially ripped off. The OS on the other drive should be OS X 10.5.8 (I know, OS X is Apple). Also, at startup, the fan will gradually increase its speed until it sounds like it's at its max - regardless it is very loud. Not sure about the rear fan; it's on it's last legs. Not sure about any RAID configurations, as I'm not familiar in that area. The HDD(s) will have power going to them, and sound perfectly fine at startup.

0 Kudos
2 Replies
7- Gold

RE: AHCI BIOS not present/No device found

Hi Logieonecanobie,

Have you tried running the diagnostics? Have you tried booting from a CD or flash drive? If you can get into the BIOS, have you tried setting the controller mode to ATA?

0 Kudos

RE: AHCI BIOS not present/No device found

I did run the diagnostics, and everything was fine. I made a Windows 10 USB installer that I ran. Everything went fine until the installer couldn't find anywhere to install the OS. I believe I did change the controller mode to ATA, but it didn't do anything. I'll make sure it's in ATA when I have the chance.

0 Kudos