Accessing data on external hard drive labeled as Unallocated

I need help with a Maxtor One Touch II external hard drive that has worked well for several years, but is now showing up as “unallocated.”  I had used this drive to back up files prior to reinstalling XP SP2.  The reinstall went well, and I decided to begin copying the files from the One Touch drive back to the C drive.  I dragged one file onto the desktop, then I realized that I had not yet installed the One Touch software.  I installed the software and restarted.  At this point I could no longer see the One Touch drive on My Computer.  In Disk Management the disk did not appear in the top panel, and in the bottom panel it appeared with the label “Uninitialized” or something like that.  I consulted the Maxtor installation instructions and realized I should have installed the software prior to connecting the drive to the computer.  I did a System Restore, installed the software, and then connected the drive to USB 2.0 port, as I always had in the past.  It still did not appear on My Computer, and it showed up in Disk Management as uninitialized.  I tried this several times more, with the same result.  At this point I tried to install the drive in another similar computer.  It still didn’t show up My Computer, but Disk Management indicated the drive was “Unallocated.” 

I moved the drive back to the first computer, where it now shows up as unallocated.  It appears in Device Manager under Disk Drives.  Maxtor also appears lower in the Device Manager list as Maxtor Personal Storage Security and under USB Controller.  The blue light in the One Touch button is going on and off with a period of about 1 second.

I need help recovering the data on the drive.  I had backed-up all of my original files on this drive, so I cannot afford to lost the files.  What can I do?

My computer: 

Dell Dimension 8200

Windows XP, SP2

Pentium 4 CPU, 2.26 GHz

512 MB RDRAM  

80 GB hard drive, Maxtor D740X-6L

Maxtor One-Touch II USB/FireWire 300 GB external hard drive

NVIDIA GeForce4 MX 420 video card

0 Kudos
1 Reply

Re: Accessing data on external hard drive labeled as Unallocated

Same issue was resolved here using Acronis Disk Director Suite (Recovery Expert) to repair the MBR on the Maxtor one touch, recovering all the data.
0 Kudos