Can’t Install OS from Bootable USB Drive on Dell Poweredge

Today I ran into a real muthaF of an issue.  We purchased a brand new Dell PowerEdge T430 server for a client, it shipped, we un-boxed and then when we proceeded to ATTEMPT to install Windows Server 2016 via USB we ran into a “small” problem, we couldn’t install a Windows Server OS from a bootable USB drive on a PowerEdge T430.


Every time we attempted to boot to the USB drive, it gave us an error about ‘no bootable media’.

I’ve used this bootable USB drive on other servers and even attempted it on my laptop to confirm it was a bootable USB thumb drive.

I tried other ports, **bleep** around with BIOS settings, tried installing the O.S. through the Lifecycle controller menu and then finally resorted to the Google machine and finally called Dell support who notified me that…
Dell PowerEdge T430’s out of the box BIOS 2.4.2 build doesn’t support UEFI on USB Drives.  

What does that mean in layman’s terms? It means Dell is a bunch of dip**bleep**s and they released a brand new server with a BIOS version that doesn’t support installing a Windows Server Operating System via your standard USB configuration.

How does a BIOS version get released that can’t support installing the OS from a standard bootable USB drive format, I mean **bleep**ing really!?

 
So, here are your options when it comes to installing a Windows Server Operating System on your Dell Server:

 

Option 1:  Create a DVD of the O.S.  This is a fine solution except for the fact that the ISO of Server 2016 is 6.8 GB and a lot of people are probably googling this in a scenario where they don’t have a dual layer DVD on them.

Option 2:  I received a comment from one, Jack , who recommended a program that will properly format a USB drive to adhere to the standards set forth by the buttholes over at Dell.  


    1. Format your USB stick  to UEFI and GPT by downloading the tool
    2. Start the tool as administrator
    3. Select the USB storage device then make the partition scheme and target system type to be GPT “partition  scheme for UEFI”.
    4. Give it the ISO image of windows server 2016 or whichever O.S. you are installing and let the tool create  the bootable USB.
    5. In the server boot settings make it UEFI and then make the partition GPT.

 
If for some reason those options don’t work, here is a last ditch option for you…

 

Nuclear Option: Install the Windows Server OS via the iDrac

For those of you unfamiliar with the iDrac, it’s a fairly convenient piece of hardware in Dell servers that allows you to remotely control the server via a Web GUI. You can power the server off/on, take remote control at the BIOS level and do some really cool stuff that comes in handy for remote admins lime myself

So, if you can’t get the DVD, like me, or you don’t have a USB stick because you are working remotely, the iDrac mighty be your only option.

Problem with this is that you will need to install a trial 30 day license of the paid iDrac product (which Dell had to send to me during our support session).

We had to put the Server 2016 ISO on my laptop, boot the server to virtual media using the iDrac and then wait FOREVER while the OS installed over the network.


If you want to know how to install a Windows Server operating system via the iDrac here you go:

 

    1. Copy the ISO of the O.S. you want to install to a local machine
    2. Configure the iDrac from the BIOS settings of the server
        1. Plug a network cable into the iDrac NIC on the server
        2. Give the iDrac card an IP address via the BIOS
    3. Now, from your local machine, go the Web GUI in Chrome using the IP Address of the iDrac card
        1. The login is root/calvin
    4. From the Virtual Console in the iDrac, go the ‘Virtual Media‘ menu on the iDrac remote session and select the ISO
        1. Remember, this requires a fully licensed iDrac
    5. Go to the ‘Next Boot‘ menu and choose the ‘Virtual CD/DVD/ISO’ option
    6. Reboot the server from iDrac and it should boot directly to the installer or at least recognize it as bootable media

    Note – We actually had to run the OS install by booting to the Lifecycle controller instead of directly from the    USB to get it to work and then we still had to choose ‘manual mode’

If your doing the iDrac option be aware that the process is extremely slow. Hopefully you can go the DVD route or Rufus, or perhaps by the time your reading this there is a new BIOS version out there and can avoid this headache.

0 Kudos
3 Replies
bthorsberg
1 Copper

Re: Can’t Install OS from Bootable USB Drive on Dell Powered

Where can I find the tool you mentioned in Option 2?

 

0 Kudos
bthorsberg
1 Copper

Re: Can’t Install OS from Bootable USB Drive on Dell Powered

https://www.lmeservices.com/bootable-usb-drive-dell-poweredge-t430/

 

perhaps this is the tool and information that you attributed to "Jack"?

Highlighted
TheAccuser
1 Copper

Re: Can’t Install OS from Bootable USB Drive on Dell Poweredge

I just wanted to report back what happened to me today.  I'm setting up a new PowerEdge T430 and ran into the same issues.  Could not get a Server 2019 USB to boot.  Tried both GPT and MBR and couldn't get either to boot.  My final solution ended up being creating the USB as GPT, but it would only successfully boot from the rear USB ports!  If plugged into the front, it wouldn't boot.  Not sure if this will help others, but thought I would report my findings.

0 Kudos