faysals
1 Copper

Factory Installed Softwares

I did a clean install of windows 7 on my studio xps 16. As expected, all the factory installed softwares are gone. Dell isn't letting me download them for who knows what reason. I just want the PowerDVD software, so I can start watching blu rays again.

Any idea how I can get it, or any other free alternatives?

0 Kudos
3 Replies
TheRealFireblad
4 Ruthenium

Re: Factory Installed Softwares

Welcome to the forums emoticon.Yes.title

 

 

You should've received various discs with the laptop - including one for PowerDVD (SE?)... unless it was only a trial version of the program course?

If you didn't get discs, you can request 'backup' discs here emoticon.Wink.title

 

If it was only a trial version, you'll have to download the latest version of PowerDVD directly from the Cyberlink website.

But you'll have to pay for it eventually... and it's not cheap!

From experience, I've found that:   “Beauty is in the eye of the beer-holder”!!

 

XPS M1730:

Smoke Grey Magnesium Alloy Chassis - with White LED Backlights
17" UltraSharp WUXGA Widescreen TFT (1920 x 1200) with TrueLife
Intel Core 2 Duo Processor T9300 @ 2.50GHz (800 MHz FSB, 4MB L2 cache)
4GB (2x 2GB) Patriot Signature PC2-5400 @ 667MHz
DUAL 512MB Nvidia 8800M GTX cards in SLi + 128MB Ageia PhysX
640GB SATA II (2x 320GB WD Scorpio Black 7200rpm)
8x Super-Multi DVD±RW
Creative X-Fi Notebook (ExpressCard) + Creative GigaWorks T40 Series II
Integrated 2MP Webcam
Dell Wireless 355 Bluetooth 2.0 Module
Intel Next-Gen Wireless-N Mini-Card
TV Tuner and Dell Travel Remote Control
4-in-1 Flash Card Reader (SSD/MMC/MS Pro/xD)

230W AC Adapter / 9-cell Lithium-Ion Battery

Windows 7 Home Premium (64bit)

0 Kudos
RobinBredin
4 Ruthenium

Re: Factory Installed Softwares

Hi Faysals, Have you tried your My Dell Downloads for your software.

      

If my answer Was helpful?  Please let me know by clicking on the 'Did this answer your question' and clicking on the Yes button.  Thanks.


 

 

0 Kudos
faysals
1 Copper

Re: Factory Installed Softwares

I have tried it, many times. It always gets stuck at the "Register Your System" page. When I check the agreement box and click "Register System" button it doesn't take me anywhere. I've tried using Firefox, IE, and Chrome. All of these browsers are up to date.

0 Kudos