Serpentwolf
1 Copper

M15X CD/DVD Drive Issues

I have an Alienware M15X that has had several issues. I have gotten them fixed with my warranty in the past, one issue was with the power cord and the other issue was with the CD/DVD drive. Now I am having an issue with my CD/DVD drive again, when I put a disk in it starts the whirring noise for like 1-2 seconds, then stops and makes clicking "tsk" noises for a few seconds. It does this cycle a few times before stopping and popping up asking me if I want to burn a disk with the supposed blank disk I entered.
The driver is up to date, I've uninstalled/reinstalled, system restored, nothing seems to help. This being the second time this problem has happened, it's beginning to get very frustrating.

TSSTcorp DVD+-RW TS-T633C ATA Device

One reason I need my disk drive to work is so I can do a complete system restore, the last time I did a complete system restore my Alien Respawn was gone so it installed normal Windows 7 instead of the Alienware Windows 7. But if my disk drive doesn't work I can't use my system disk.

0 Kudos
3 Replies
7- Gold

Re: M15X CD/DVD Drive Issues

Hi Serpentwolf,

What I would do is test your drive using the diagnostics. I'm not sure if Alienware systems have the same setup, but on a Dell, you hit F12 while booting and select utility partition.

0 Kudos
Highlighted
Serpentwolf
1 Copper

Re: M15X CD/DVD Drive Issues

I'm sorry, I didn't receive the email saying I got a response. I tried this option, F12 took me to the Boot Menu, I hit Diagnostics, it was running fine until it got to a part where colored lines went across the screen and asked me if I seen the colored lines <y/n> but pressing y didn't do anything, neither did n. And I didn't see anything for Utility Partition either, it just started the Diagnostics as soon as I hit enter.

0 Kudos
7- Gold

Re: M15X CD/DVD Drive Issues

As I said, I'm not familiar with Alienware. You might want to post in the Alienware forum.

0 Kudos