Highlighted
jbmoondog
1 Nickel

Plextor DVD drive not responding ?

XPS 420, installed a Plextor DVD drive that will read, boot etc. ONLY from Dell disks?  I've loaded updated drivers/firmware for the DVD from a memory stick just fine.  I still cannot get the ROM to read or autostart on the other install disks I have for wireless card and sound card.  Just no response.

Thoughts?  Suggestions?

Thanks,

John

0 Kudos
3 Replies
8 Krypton

Re: Plextor DVD drive not responding ?

Hi, jbmoondog:

I'll hazard a guess that this is an SATA drive. First, make sure the SATA channel to which this drive is connected is turned on in the BIOS. That's a commonly overlooked installation requirement.

Have you tried reading these discs in safe mode? A command prompt? Tried running the diagnostics with one of them?

0 Kudos
jbmoondog
1 Nickel

Re: Plextor DVD drive not responding ?

Yes, SATA drive.  Yes, the channel is turned on in the bios.  No, I have not tried reading discs in any other mode.  Is there an easy place to find instruction for that sort of thing?  I'm new at playing with hardware and this is the first time I have worked with a Dell machine.

Could be that part of the issue is that I started with the box, motherboard and power supply.  That's it.

I used my vista restore disk from my xps 1530 to "install" the operating system over a HDD that had XP on it.  Maybe, I'm really whacked trying to revive this 420 this way!

I don't have a driver/utilities disk which could be part of the issue?

Thanks,

John

0 Kudos
8 Krypton

Re: Plextor DVD drive not responding ?

As long as you're working with the Dell motherboard, there shouldn't be any problems. And no, you're not whacked! emoticon.Stickouttongue.title

All of the drivers can be found in downloads. Click the support button at the top of any forum page to get to downloads. It's possible that once all the drivers are installed, the drive will read just fine.

There's also a possibility the Plextor is just not playing well with your setup.

0 Kudos