mjwboofer
1 Copper

Replaced SATA Drive - Vista Could not see files on old SATA drive - Ubuntu could

I have an Inspiron 531 and got a new SATA drive for it. I wanted a clean Vista install and then planned to copy some of my folders from the old drive. So, I did NOT want to clone the old drive for multiple reasons (primarily Vista booted to a black screen with mouse cursor after a chkdsk mishap?).  I figured the quickest way would be to install Vista (from Dell OEM CD) on the new drive and then connect the other drive and copy the desired files.

Unfortunately, when I connected the old drive, Vista could tell it was there in "My Computer".  I could see all the files in the Dell Recovery partition but could not see any files nor tell the size;of the old Vista OS partition. If anyone has a solid explanation why this was the case, I'd be interested.  My theory is that there's something about that Dell-created partition that Vista just didn't like (when it's not the boot drive).  Or, perhaps the same issues that prevented the drive from booting properly also prevented it from being viewed?

I booted a Vista Recovery CD with only the old drive and a USB drive connected and, via the command prompt, could see the directories. In this very cumbersome DOS format, I tried to copy some directories (using the ROBOCOPY command) and ended up with some errors. I abandoned this approach.
A few threads found in my searching suggested using a "Live Boot CD" and mentioned Ubuntu. I had a Ubuntu CD handy, purely out of coincidence and dubiously dropped it in the CD Drive. From there, after a long but effective boot-OS-from-CD, I was able to surgically copy all of the directories I wanted from the old drive to the USB drive. The only reason they didn't go directly to the new SATA drive is the dumb fact that I only had 2 SATA cables (3rd is on its way).

I'd be interested in any comments about why this was not nearly as simple as I had hoped. I hope this will be useful to someone trying to do something similar.

0 Kudos
1 Reply
7- Thorium

Re: Replaced SATA Drive - Vista Could not see files on old SATA drive - Ubuntu could

Hi Mjwboofer,

I think this could have been solved by following the "take ownership" procedure for Vista.

Anyway, glad you were able to get everything using Ubuntu.

0 Kudos