3 Argentum

XPS 8700 BIOS doesn't see all bootable drives (I broke it it seems)?

I did a dumb thing trying to get W10 on the PC. I have 2 bootable drives, an SSD and the original Dell delivered hard drive. When W10 install to the SSD went to reboot it appears to go to the hard drive, not the SSD I was trying to install it on. I opened the BIOS and on the BOOT tab under HARD DRIVES I selected the hard drive and DELETED it so I'd only have the SSD showing.

Turns out this appears to control the menu via F12 which I used to boot the Hard Drive. Only problem is NOW I can't add that drive back! Re-installing the V11 BIOS using /FORCEIT doesn't help.

How can I add that drive back into the HARD DRIVE list?

My BIOS F12 screen showed 3 boot choices before.

Windows Boot Manager 1 is the SSD... and is the normal boot. The original Hard Drive with the original C: partition is Windows Boot Manager. DVD and USB device if they had a boot sector.

Deleting the drives in the BIOS didn't 'fix' the W10 install issue and later I discovered I needed to re-install W8.1 to the SSD (and I had ALL drives attached), restore my W8.1 image and THEN W10 installed the upgrade.

So now I want to PUT BACK the 2 drives I deleted (UEFI OS had always booted to the SSD) as these seem to control what appears on the F12 boot menu.

This is what I see now for F12 is ONLY the SSD called Windows Boot Manager. No other boot choices (unless a DVD or USB boot device is in).

The SSD became Windows Boot Manager once the other drives were deleted.  The Original Hard drive doesn't show on the BOOT tab anymore (don't need the UEFI OS) and I want it back.

There is NO ADD drive capability it seems?

I've reloaded the V11 BIOS using /FORCEIT and there was no change. I've removed the SSD and then NOTHING appears and I can't boot. The ESP partition is on the ORIGINAL Hard Disk and it appears it only points to the SSD. I do SEE both drives when Windows starts booting loading from the BCD I think in the ESP partition:

That is the Windows Boot Manager showing both drives.

This is the only way now I can boot the Original Hard drive (Windows 10 HD) but I'd rather see it in BIOS and boot via F12.  I can delete the hard drive entry and I'll not see that screen. Using F9 in the BIOS to restore the defaults didn't work either?

BTW, e-mail with Dell support is useless. 4 e-mails exchanged and all the tech seems to get it that I want to know how to change what drive I boot off of. He finally stopped responding after I tried to explain it again.

I'm pretty sure the UEFI data is messed up but I can't figure out how to correct it? I've got EasyUEFI to look at that data and it doesn't seem to offer me any help as it sees two disks bootable.

Suggestions?

0 Kudos
2 Replies
3 Argentum

RE: XPS 8700 BIOS doesn't see all bootable drives (I broke it it seems)?

Have you tried resetting the bios?  I was running into a similar problem and reset the bios.  Afterwards I could see the missing drive.  I had to go back and manually modify those bios settings I had changed previously.

0 Kudos
3 Argentum

RE: XPS 8700 BIOS doesn't see all bootable drives (I broke it it seems)?

Have you tried resetting the bios? 

If you mean using F9 while in the BIOS, yes. Also tried forcing the re-install (which seemed to work) of V11.

When I disable Secure Boot and UEFI I do see ALL the drives in F12's menu but not under the HARD DRIVES? Of course with those settings W10 will not boot in the SDD.

Is there another way to reset the BIOS? Do you mean the RTCRST clearing? I thought that only did the PASSWORD reset?

0 Kudos