1 Copper

XPS/Dimension 630i nvgts.sys error trying to load drivers

Brief background the SATA Optical DVD drive failed and my hubby didn't tell me about a month ago.  Now he can't log on due to the infamous missing/corrupt nvgts.sys file.  I've researched it via the web, but have not found any firm solutions except after trying to reseat connectors or reinstall operating system.  I'm really trying not to re-install as his last back up was a week ago and he had just finished converting some major files to flash when this happened.  

I have gotten the optical drive to work and put in the OS disk in drive and boot to the repair mode.  So now I have the new drivers, no floppy drive and a DOS interface.  How do I load the nVidia drivers and hopefully get this resolved. 


Any other options out there outside of the obvious pull data prior to rebuild etc.




System Info:  (Couldn't get to my account information online - system down so some information may not have item brand/details)

-- XPS 630 --
-- Intel® Core蒂2 Q6600 Quad-Core (8MB L2 cache,2.40GHz,1066FSB)
-- Memory --
-- 4GB Dual Channel DDR2 SDRAM at 800MHz - 4 DIMMs
-- Dell USB Keyboard
-- Video Card --
-- nVidia GeForce 8800 GT 512MB
-- Hard Drive --
-- 320GB - 7200RPM, SATA 3.0Gb/s, 16MB Cache
-- Windows XP Pro
-- Mouse --
-- Dell Optical USB Mouse
-- [310-9573-
-- Optical Drive --
-- Single Drive: 16X CD/DVD burner (DVD+/-RW) w/double layer write capability
-- Sound Cards --
-- Integrated 7.1 Channel Audio


0 Kudos
3 Replies
8 Krypton

Re: XPS/Dimension 630i nvgts.sys error trying to load drivers


You said the drive failed? Do you mean a hardware failure? Did you run the diagnostics?

I'm not familiar with nvgts.sys but it appears to be a driver for an NVidia chipset. Did you go to downloads and check for an update? You can get to downloads by clicking Support above.

"My hubby didn't tell me..." Wow, reminds me of, "Dad, when are you going to fix my computer!!!" Uh, as soon as you tell me what's wrong with it.

0 Kudos
8 Krypton

Re: XPS/Dimension 630i nvgts.sys error trying to load drivers

Try downloading and reinstalling the Chipset driver from Dell LINK or going to nVidia who has a newer version LINK than Dell which is from 2006. You might even want to download the newest ESA software from nVidia. LINK

Hope this helps.

Alienware Aurora R4: i7-3820, 8GB, 10TB of HDD, AMD/ATI Radeon HD 7800, Samsung 27" monitor

XPS 730x: i7 920,   Replaced with an Alienware Aurora R4

XPS 410: Core 2 Quad 2.4GHz (Q6600) , 6GB, EVGA 8800GTS 640MB,
Single TV Tuner , X-Fi Xtreme Music, Logitec X530 Speakers

Latitude 10 Tablet

Inspiron 1720: T7500, 4GB, 120GBx5400, 120GBx7200, 8600GT, DVD+/-RW, Bluetooth,
Windows 8.1

0 Kudos
1 Copper

Re: XPS/Dimension 630i nvgts.sys error trying to load drivers

Well, there were two problems

  • the failure of the optical DVD
  • the error on start of the missing or corrupt nvgts.sys file

I researched the nvgts.sys file issue and that is when I found out that it is related to the chip set/control of the SATA drives.  In particular the Optical Drive.  I ran all of the diagnostics and was unable to communicate with the optical drive and received two errors on the USB Disk, which failed an internal test.  The external USB Disk was old so I was not surprised.  Everything else was fine.  No issues were found with either of the SATA hard drives. 

One solution suggested was to unplug the optical drive and try to start windows.  That didn't work so I decided to go ahead and try for the windows /r.  I reseated the optical drive connections as I was going to need it to load the windows CD and only reconnected the monitor, mouse and keyboard.  Still no go so I went into Windows /r.

I am now in a DOS like command line interface with my C drive as the root.  I can not find anything but the C drive.  I have the latest drivers and I happen to have the exact same computer at work so I have copied the nvgts.sys file, but I'm not sure if it's going to see my thumb drive at this point.  I also don't have a clue if it's even possible to load a driver from this command line.

I have a few old computers that I can dig up a working floppy drive to install, but I'm kind of back to square one there as I would need the drivers or am I wrong.

If there is any more information you need let me know.  I am an old time geek and this for some reason has me flustered.  emoticon.Geeked.title




0 Kudos