SupportAssist for PCs

Last reply by 04-19-2022 Unsolved
Start a Discussion
2 Jasper
2 Jasper
21696

Driver Detection Not Available

Hello,

Lately, I seem to be unable to have the support website automatically scan my computer for driver updates. For the past few weeks, whenever I go to the support page for a specific model (desktop or latpop), I go to "Drivers & Downloads", I click on "Detect Drivers", it appears to search for a few seconds, then comes back with "Driver Detection Not Available". I'm seeing this happen on multiple systems. I've done a search for others with this problem and see multiple complaints about it over the past few years, but no solutions.

I do have SupportAssist on my own PC, but that's not working either.

Anybody?

Thanks in advance.

Labels (1)
Replies (28)
534

See my reply on 24 JAN 2022.  It worked for me.  If it works for you then please thumbs up and mark it as answer.

530


@Ahaan wrote:

Has a solution been found?


Hi Ahaan:

This thread was started in October 2020 and there are two different problems being discussed in this thread regarding driver updates. Do you have a problem when you check for updates using a Dell utility like SupportAssist and/or Dell Update, or does the problem occur when you click the blue "Check for Updates" button when you browse to the support page for your Dell computer model in your web browser?

Any additional information like your Dell computer model, Windows operating system, SupportAssist version number (if installed), and the error message you are seeing would also be helpful.
--------------
64-bit Win 10 Pro v21H2 build 19044.1645 * Firefox v99.0.1 * Microsoft Defender v4.18.2203.5-1.1.19100.5 * Malwarebytes Premium v4.5.8.191-1.0.1666 * Dell SupportAssist v3.10.4.18 * Dell Update for Windows 10 Universal v4.5.0 * Macrium Reflect Free v8.0.6635
Dell Inspiron 15 5584, Intel i5-8265U CPU, 8 GB RAM, 256 GB Toshiba KBG40ZNS256G NVMe SSD, Intel UHD Graphics 620

2 Bronze
2 Bronze
3992

I am also facing the same issue, Well, SupportAssist IS installed on my PC, but neither is working. The problem I'm having using the <Non-public info removed> version has been consistent on multiple PCs & laptops. I can't vouch for every single one of them, but I do know that SupportAssist is installed on several of them. It's only because it didn't seem to be working that I even tried to check the website manually in the first place.

2 Bronze
2 Bronze
1879

Me to.

1873

Hi Alif Aqil:

What is your Dell computer model, Windows operating system and current version of Dell SupportAssist? Launch SupportAssist and go to Options (gear icon) | About SupportAssist to see if you have the current v3.9.2.57.

Dell SupportAssist v3_9_2_57 Settings About 01 Jul 2021.png

When you say you "Me too" does that mean that you have the same problem as the original poster gtifeld123 and that the "Check for Updates" button on the Drivers & Downloads tab of the Dell support page for your computer model isn't detecting available updates? Does a check for updates run normally when you use Dell SupportAssist and/or Dell Update?  If not, do you see a warning or error message, or is there a specific update (e.g., the SupportAssist OS Recovery Tools) that fails to install correctly?

Note that this is an older thread that was started in October 2020, and most users were able to fix their problem by either installing SupportAssist or performing a reinstall of SupportAssist and all its associated components (see DELL-Chris M's instructions at SA Uninstall / Reinstall).
-----------
64-bit Win 10 Pro v20H2 build 19042.1052 * Firefox v89.0.2 * Microsoft Defender v4.18.2105.5 * Malwarebytes Premium v4.4.2.123-1.0.1358 * Dell SupportAssist v3.9.2.57 * Dell SupportAssist Remediation v5.4.1.14954 * Dell Update v4.2.1
Dell Inspiron 15 5584, Intel i5-8265U CPU, 8 GB RAM, Toshiba KBG40ZNS256G 256 GB NVMe SSD, Intel UHD Graphics 620

2 Bronze
2 Bronze
1107

I'm having the same issue. Uninstalled and reinstalled Support Assist multiple times. Dell can pull my Tag in a browser, but still nothing.

G7 7790   

Processor Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz 2.59 GHz
Installed RAM 16.0 GB (15.8 GB usable)
Device ID 851644F9-4CCC-47E1-BA11-0D303F5B4E72
Product ID 00325-81402-85562-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

1107

Hello, I see you are looking for technical assistance. If you need our help, you can start a direct message with us and we will be happy to assist you.


Social Media Support

#IWork4Dell
Find your Service Tag


If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

1101

I was having the same issue, I couldn't get the Drivers and Download page of the Dell Support website to scan my Dell computer.  I have both Dell Support Assist and Dell Update installed on my computer.

The issue for me was being caused due to "Dell Client Management Service"  not running nor starting Automatically.  Here are the steps I took in order to fix the issue for me.

  1. Search for and open the services app.
  2. Within the Services app find Dell Client Management Service, double-click on it, or right-click and open properties.
  3. In the newly opened properties window ensure that the following:
    • Startup Type is set to "Automatic".
    • Services status is running, if it isn't then click on Start to begin the process.
  4. Click Apply on the bottom right of the properties window.
  5. Click OK on the bottom left of the properties window.
  6. Now attempt to update your computer from the Dell Support website via the "check for update" button and it should work again.

This worked for me.  If it works for any of you Thumbs up via the Kudos button and mark my post as Answer.

2 Jasper
2 Jasper
1101

I was having the same issue, I couldn't get the Drivers and Download page of the Dell Support website to scan my Dell computer.  I have both Dell Support Assist and Dell Update installed on my computer.

The issue for me was being caused due to "Dell Client Management Service"  not running nor starting Automatically.  Here are the steps I took in order to fix the issue for me.

  1. Search for and open the services app.
  2. Within the Services app find Dell Client Management Service, double-click on it, or right-click and open properties.
  3. In the newly opened properties window ensure that the following:
    • Startup Type is set to "Automatic".
    • Services status is running, if it isn't then click on Start to begin the process.
  4. Click Apply on the bottom right of the properties window.
  5. Click OK on the bottom left of the properties window.
  6. Now attempt to update your computer from the Dell Support website via the "check for update" button and it should work again.

This worked for me.  If it works for any of you Thumbs up via the Kudos button and mark my post as Answer

Latest Solutions
Top Contributor