Highlighted

SupportAssist update (3.1.30) does not work

I have an Ispiron 5770 with windows10.

If I click on the SupportAssist icon in my Start Menu it tries to load SupportAssist version 3.1.30 - and it simply hangs at the loading screen.

If I search the control panel it gives me SupportAssist version 3.02.48 wirt a 148MB size.

My antivirus is McAfee.

What's wrong with the update and why I have 2 versions running on the PC?

 

I tried the workaround that's in another thread (i.e.

  1. Open command prompt as admin
  2. run "cd C:\Program Files\Dell\SupportAssistAgent\bin"
  3. run "SupportAssistUI.exe launch" )

but it freezes while scanning the hardware.

Any ideas how can I solve the problem?

Thanks

Fabrizio

0 Kudos
9 Replies
Highlighted
7 Thorium

Re: SupportAssist update (3.1.30) does not work

You don't need to have support assist installed at all. Uninstall both versions, one at a time and reboot the computer after each uninstall. You can always reinstall it if you want to use it. Support Assist is useful for beginners but it can cause problems at times.

See this-- https://www.dell.com/support/contents/us/en/04/article/product-support/self-support-knowledgebase/so...

0 Kudos
Highlighted
1 Copper

Re: SupportAssist update (3.1.30) does not work

Hello! I'm actually having the same problem with mine at the moment. Is there a solution to this which involves maybe not uninstalling SupportAssist completely? I actually quite like using it and would like to continue to do so in the future. 


I have the same issue, where SupportAssist loads as 3.1.0, but is listed in Control Panel as 3.0.2.48, or something similar. SupportAssist when opened then doesn't get past loading. It just keeps unendingly showing the little four square loading icon and never progresses. Would maybe a reinstall be worth trying?  


0 Kudos
Highlighted
3 Argentum

Re: SupportAssist update (3.1.30) does not work

Same problem but on my Alienware 15 R3... Nice job Dell.

0 Kudos
Highlighted
Moderator
Moderator

Re: SupportAssist update (3.1.30) does not work

Hi amack,

Dell SupportAssist 3.1 AppX was accidentally pushed to production and customers in the US region may have installed the application through the Microsoft Store. Version 3.1 has been taken from production and replaced with SupportAssist 3.0.2 AppX at the Microsoft Store, which is the only version which should be available for customers at the Microsoft Store.

I would appreciate if you can send me personal message with your email id so I can share the automated script which can solve this issue.

Thanks

DELL-NikhilK

#iworkforDell 

 

 

0 Kudos
Highlighted
1 Copper

Re: SupportAssist update (3.1.30) does not work

Dell-Nikhil K,

 

I don't seem to be able to send you a private message. Is there any way you can share the script with the group?

 

Thanks,

klinkny

0 Kudos
Highlighted
2 Bronze

Re: SupportAssist update (3.1.30) does not work

I have the same problem with SupportAssist.  It was working fine a week or so ago now it hangs after it launches.  It's version 3.xxx something.  It looks different than it did previously.  I did not download any update but there was a Windows Update or two.  I have a Latitude 3470, Windows 10 Pro, Windows Defender, Malwarebytes.  What is the solution for this?  Thank you.

0 Kudos
1 Copper

Re: SupportAssist update (3.1.30) does not work

Same problem here. Windows 10, Latitude 7480 and the SupportAssist does not respond after starting it up. ALSO my docking station (DW15) does not recognize my external monitors anymore. 

I'm really getting frustrated  with crappy products of Dell!!!

0 Kudos
Highlighted
1 Copper

Re: SupportAssist update (3.1.30) does not work

I have been the same issue on Latitude 7480, Windows 10 Pro, SupportAssist version 3.0.2.48.

But if you'll uninstall it, download and install new version from official site - SupportAssist should will have to work. This actions have helped me.

0 Kudos
Highlighted

Re: SupportAssist update (3.1.30) does not work

Dell SupportAssist automatically updated and is not operational.  Version 3.1.x on Windows 10.

Been non-operational for nearly 2 weeks now - when is a fix expected?

0 Kudos