DMX Masking / Linux Server

Jump to solution

Dear SAN Admins:

I am trying to add a couple of LUNS to a Linux Server after a long long time. (which already has a few LUNs from the very same DMX). I am sure I am missing something. I am unable to discover the LUNs on the Linux Box. I get these messages in the log file of the Linux Server. 

 

May  1 14:09:50 kernel: scsi: host 0 channel 0 id 0 lun99 has a LUN larger than allowed by the host adapter

What would you suggest? Any input would be most appreciated.

KGD.

May  1 14:09:50 kernel: scsi: host 0 channel 0 id 1 lun88 has a LUN larger than allowed by the host adapter

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
dynamox
6 Thallium

Re: DMX Masking / Linux Server

Jump to solution

also take a look at the following article

emc202590

0 Kudos
10 Replies
dynamox
6 Thallium

Re: DMX Masking / Linux Server

Jump to solution

are you using dynamic lun masking ? If not, what was the FA address you mapped this device to ?

0 Kudos
dynamox
6 Thallium

Re: DMX Masking / Linux Server

Jump to solution

also take a look at the following article

emc202590

0 Kudos

Re: DMX Masking / Linux Server

Jump to solution

Dynamox:

Thanks for your prompt response once again. Nope I have not used Dynamic LUN Masking. I used FA ports # 13B and # 4B. Since I had no luck, I later moved it to Port # 13A and 4A. No luck after I moved it too. There is a bit setting which we had to do I think for this issue. I am unable to recall what it is.

0 Kudos
dynamox
6 Thallium

Re: DMX Masking / Linux Server

Jump to solution

are you using the same FAs that the system is currently using ? What address on the FA did you map your device to  ?

map dev 5365 to dir 14c:0 lun=06F;

map dev 5365 to dir 14b:0 lun=06F;

0 Kudos

Re: DMX Masking / Linux Server

Jump to solution

Dynamox:

I used the same FAs that the system is currently using.

I went through the document that you sent me. The VOLS bit using symmask was disabled on both the HBAs.

A refresh was run on the array:

# symmask -sid 1234 set hba_flags on V -disable -wwn 500110a0000000bb -dir 13B -p 0

# symmask -sid 1234 refresh

The only thing I can think of now is reboot the Linux Server and try to see if that makes any difference.

0 Kudos
dynamox
6 Thallium

Re: DMX Masking / Linux Server

Jump to solution

you are not answering my question , what address on the FA did you use to map your device ?

0 Kudos

Re: DMX Masking / Linux Server

Jump to solution

Sorry Dynamox:

I mis-read your question.

This is what I did:

map dev 0234 to dir  4b:0, vbus=1 target=0F, lun=003;

map dev 0234 to dir  13b:0, vbus=1 target=05, lun=000;

0 Kudos
dynamox
6 Thallium

Re: DMX Masking / Linux Server

Jump to solution

a couple of things

1) you are not using the same address on both FAs ? IE:

map dev 0234 to dir  4b:0, vbus=1 target=0F, lun=003;

map dev 0234 to dir  13b:0, vbus=1 target=0F, lun=003;

2) since you are specifying vbus, i assume you have HPUX systems on these FAs ?

3) can you post "symdev show" from a device that is currently connected and working on this host

Re: DMX Masking / Linux Server

Jump to solution

Dynomax - Thanks for your help on this. We did have to reboot the server to finally discover the LUNs. A reboot has always resoved problems on Linux boxes in the past also. There is a way Systems Administrators discover/rescan LUNs without a reboot on Linux Servers but in my experience it has worked 9 out of 10 times.

Also thanks for the document that you pointed out.

0 Kudos