Highlighted
pranav_pune
2 Iron

HBA Port entry disappeared from VCMDB

While doing some operations I suspect I have deleted entry for host HBA port from VCMDB. When I run symmaskdb llist logins I do not see my host HBA entry. When I run symmask list hba -v, I am able to see the hba on the host. When I run symmask discover hba I see no HBAs discovered.

[root@chania pranav]# symmask list hba

Identifier        Type   Adapter           Physical Device Path      Dir:P
----------------  -----  ----------------  ------------------------  -----
210000e08b925b19  Fibre  210000e08b925b19  /dev/sdc                  16D:1

[root@chania pranav]# symmask list logins | grep 210000e08b925b19

[root@chania pranav]# symmask discover hba

Symmetrix ID          : (null)
Device Masking Status : No HBA found in Login History Table


  Identifier        Type   User-generated Name
  ----------------  -----  ---------------------------------
  N/A               N/A    N/A

[root@chania pranav]#

But still I can see devices and fetch info from storage array using SYMCLI commands. I am not getting on how can I recreate the entry for my disappered host HBA port.

0 Kudos
7 Replies
pranav_pune
2 Iron

Re: HBA Port entry disappeared from VCMDB

Got it. REBOOT of the host machine did the trick. But still do not know why this behaviour was occuring.

sauravrohilla
3 Cadmium

Re: HBA Port entry disappeared from VCMDB

When you reboot the host, HBA does the login on the FA port and updates the login table.

0 Kudos
pranav_pune
2 Iron

Re: HBA Port entry disappeared from VCMDB

How can I initiate HBA login manually? Without reboot.

0 Kudos
sauravrohilla
3 Cadmium

Re: HBA Port entry disappeared from VCMDB

bounce the switch port to which WWN is connected even that forces login to FA and updates the login table.

0 Kudos
pranav_pune
2 Iron

Re: HBA Port entry disappeared from VCMDB

My masked devices are disappeared now. Do I need to mask them again to the host HBAs?

0 Kudos
sauravrohilla
3 Cadmium

Re: HBA Port entry disappeared from VCMDB

No, masking should remain as it is.

0 Kudos
pranav_pune
2 Iron

Re: HBA Port entry disappeared from VCMDB

Disks are disappeared. Something went wrong I guess.

0 Kudos