rstickalnd
2 Bronze

cluster enabler - no plugins installed on the node

dell r620 windows 2k8r2 Microsoft SQL cluster :  issue:  when I install cluster enabler on my sql server and go to configure cluster enabler, the validation page comes back as failed with the message "no plugins installed on the node"  mscs is installed and running as well as solutions enabler 7.5.  any suggestions?

Actions so far include running cluster enabler again and uninstalling and reinstalling Cluster Enabler

0 Kudos
3 Replies
sauravrohilla
3 Cadmium

Re: cluster enabler - no plugins installed on the node

Is it SRDF/CE or MVCE?

What is the version of the CE?

Have you installed base and CE plugin on all the nodes?

If you have already installed BAse and Plugin on all nodes then it could be due to the WMI issue on the node. Could you please paste the CE plugin logs

regards,

Saurabh Rohilla

0 Kudos
rstickalnd
2 Bronze

Re: cluster enabler - no plugins installed on the node

SRDF/CE cluster

version 4.1.3.14

where do you find the "plug in" for cluster enabler?  i have searched for it and have not found it# EMC Cluster Enabler Log File
#
# Column [01] - Date/Time
# Column [02] - Process ID
# Column [03] - Thread ID
# Column [04] - Username
# Column [05] - Serverity
# Column [05] - Cluster Group Name
# Column [07] - Computer Name
# Column [08] - Component
# Column [09] - Module
# Column [10] - Message
# Column [11] - Location
#
# NOTES:
#
# [1] - The times reported in this log are expressed in Coordinated Universal Time (UTC).

2012/12/12-22:13:27.321 4320 4360 SYSTEM ERROR N/A MCG-TUL-DB01 WMI FindManifestFiles Call to FindFirstFile failed for . RC = [3]. N/A
2012/12/12-22:13:30.457 4320 4360 rstickland ERROR N/A MCG-TUL-DB01 WMI CE_SystemRegistrationServiceImpl::ExecMethodAsyncImpl No plugin is installed on node [MCG-TUL-DB01]. N/A
2012/12/12-22:15:48.303 6356 6056 rstickland INFORMATION Quorum MCG-TUL-DB01 ARB_LIBRARY CEServiceArbLibrary::CEStorageArbitration::ReadClusterCustomResTypeList Custom Resource Type List:System.Collections.Generic.List`1[System.String] 512
2012/12/12-22:15:48.428 6356 6056 rstickland ERROR N/A MCG-TUL-DB01 GUI_BL CeCluster::AreAllNodesConfigured ReadSiteList failed to read site list from cluster properties.  N/A
2012/12/12-22:15:51.224 4320 6612 rstickland ERROR N/A MCG-TUL-DB01 WMI CE_SystemRegistrationServiceImpl::ExecMethodAsyncImpl No plugin is installed on node [MCG-TUL-DB01]. N/A

# EMC Cluster Enabler Log File
#
# Column [01] - Date/Time
# Column [02] - Process ID
# Column [03] - Thread ID
# Column [04] - Username
# Column [05] - Serverity
# Column [05] - Cluster Group Name
# Column [07] - Computer Name
# Column [08] - Component
# Column [09] - Module
# Column [10] - Message
# Column [11] - Location
#
# NOTES:
#
# [1] - The times reported in this log are expressed in Coordinated Universal Time (UTC).

2012/12/12-23:16:24.452 7012 7064 rstickland INFORMATION Quorum MCG-TUL-DB01 ARB_LIBRARY CEServiceArbLibrary::CEStorageArbitration::ReadClusterCustomResTypeList Custom Resource Type List:System.Collections.Generic.List`1[System.String] 512
2012/12/12-23:16:24.624 7012 7064 rstickland ERROR N/A MCG-TUL-DB01 GUI_BL CeCluster::AreAllNodesConfigured ReadSiteList failed to read site list from cluster properties.  N/A
2012/12/12-23:16:24.795 4528 4580 SYSTEM ERROR N/A MCG-TUL-DB01 WMI FindManifestFiles Call to FindFirstFile failed for . RC = [3]. N/A
2012/12/12-23:16:24.904 7012 7064 rstickland ERROR N/A MCG-TUL-DB01 GUI_BL Node::Node(string) Cannot retrieve node information. Error 'Provider load failure ' occurred while retrieving CE_ComputerSystem object from MCG-DR-DB01. N/A
2012/12/12-23:16:26.603 4528 4580 rstickland ERROR N/A MCG-TUL-DB01 WMI CE_SystemRegistrationServiceImpl::ExecMethodAsyncImpl No plugin is installed on node [MCG-TUL-DB01]. N/A# EMC Cluster Enabler Log File
#
# Column [01] - Date/Time
# Column [02] - Process ID
# Column [03] - Thread ID
# Column [04] - Username
# Column [05] - Serverity
# Column [05] - Cluster Group Name
# Column [07] - Computer Name
# Column [08] - Component
# Column [09] - Module
# Column [10] - Message
# Column [11] - Location
#
# NOTES:
#
# [1] - The times reported in this log are expressed in Coordinated Universal Time (UTC).

2012/12/12-22:13:27.321 4320 4360 SYSTEM ERROR N/A MCG-TUL-DB01 WMI FindManifestFiles Call to FindFirstFile failed for . RC = [3]. N/A
2012/12/12-22:13:30.457 4320 4360 rstickland ERROR N/A MCG-TUL-DB01 WMI CE_SystemRegistrationServiceImpl::ExecMethodAsyncImpl No plugin is installed on node [MCG-TUL-DB01]. N/A
2012/12/12-22:15:48.303 6356 6056 rstickland INFORMATION Quorum MCG-TUL-DB01 ARB_LIBRARY CEServiceArbLibrary::CEStorageArbitration::ReadClusterCustomResTypeList Custom Resource Type List:System.Collections.Generic.List`1[System.String] 512
2012/12/12-22:15:48.428 6356 6056 rstickland ERROR N/A MCG-TUL-DB01 GUI_BL CeCluster::AreAllNodesConfigured ReadSiteList failed to read site list from cluster properties.  N/A
2012/12/12-22:15:51.224 4320 6612 rstickland ERROR N/A MCG-TUL-DB01 WMI CE_SystemRegistrationServiceImpl::ExecMethodAsyncImpl No plugin is installed on node [MCG-TUL-DB01]. N/A

0 Kudos
sauravrohilla
3 Cadmium

Re: cluster enabler - no plugins installed on the node

From SRDF/CE release notes:

Installation requirements and considerations


You should consider the following criteria before installation:

◆ The Cluster Enabler Base Component is a prerequisite for the Cluster Enabler plug-ins, and therefore must be installed prior to or with the plug-ins. For instructions on installing the Base Component, refer to the EMC SRDF/Cluster Enabler Plug-in Product Guide and the EMC Cluster Enabler Base Component Release Notes.

Also from your cluster enabler logs:

2012/12/12-22:15:51.224 4320 6612 rstickland ERROR N/A MCG-TUL-DB01 WMI CE_SystemRegistrationServiceImpl::ExecMethodAsyncImpl No plugin is installed on node [MCG-TUL-DB01]. N/A

As I had mentioned, if the plug in is already installed then it must be a problem with WMI communication with plugin.

regards,

Saurabh

0 Kudos