barunk
1 Copper

symrdf -cg cg_name -refresh R1 swap is failing

Hi,

I was trying to swap the replication of a CG & used the following commands-

Old state- RDF pair state was 'synchronized'

1. symrdf -noprompt -cg cg_name -force failover

Result- Success. For current status please refer to the image1

image1.PNG.png

2. Tried the disable command.

Result - Failed.

Output- Invalid action

3. Tried the refresh & swap command

Result- Failed. Please refer to image 2

image2.PNG.png

Please let me know how to fix this. Thanks in advance.

-Barun

0 Kudos
3 Replies
PaulCork
3 Argentium

Re: symrdf -cg cg_name -refresh R1 swap is failing

Barun,

you should never really be trying to force a failover unless directed to by support.

Failuure to swap personality may be due to flags on the 5876 code devices, check if they are dynamix RDF capable.  This is the default in 5977 but not in 5876.  you may need to set the device to be Dynamic RDF capabable.  Check on symdev show for device A54.

0 Kudos
barunk
1 Copper

Re: symrdf -cg cg_name -refresh R1 swap is failing

Thanks for the reply Paul. Will verify the suggested commands tomorrow.

When i tried to do a failover without "force" option, then the command output suggested to use the "force" parameter in the current state. As its not my production setup, have tried that. But now unable to recover from this state.

Also, do you have any idea on why "disable" option is showing as "invalid" ? Have also tried to execute this command at the node connected to other array, but got the same error message.

0 Kudos
Highlighted
PaulCork
3 Argentium

Re: symrdf -cg cg_name -refresh R1 swap is failing

is you run stordaemon list command on the host you are running you will probably see that the storrdfd daemon process is not running at a guess.  RDF Deamon needs to be running on the node where you are running the disable command.

0 Kudos