Systems Management General

Last reply by 06-05-2022 Unsolved
Start a Discussion
3 Silver

Help Request: How to send commands to IDRAC via CLI (for dummies)

That is it, my IDRAC bricked during an online update, now it doesn't start anymore, dont matter what. Ive been troubleshooting and Ive hit a wall here, trying to restart the IDRAC via RACADM. I have no idea on how to "connect" to IDRAC to input commands. It seems to be somehow similar to how I connect to my switches and routers via telnet, but I have found no documentation that a dummy like me could to understand. Are there a very simple way for me to input these reset commands to IDRAC via CLI? Can someone here guide me with that? That would be great.

Replies (4)
4 Beryllium

You can connect to an iDRAC via "remote", which needs of course proper networking and the iDRAC root credentials as well or through the Host OS when having OS root/administrator rights. So you need to install or just copy racadm + *lib*.dll into a temp folder and than you can use it.

C:\Temp>racadm help | findstr /i racreset
racreset -- perform a RAC reset operation
racresetcfg -- restore the RAC configuration to factory defaults

You can try to reset the Application on the iDRAC which needs a couple of minutes to perform or try to wipe all configuration of the iDRAC by using

racadm racresetcfg 



Thanks for the help, man. After I created this thread I continued with trying and found out that if you have an OS installed in the machine you can run the RACADM from a command prompt with ADM properties, and then to command the IDRAC from there. I've tried it and the RACADM said there was no IDRAC present. Ive used a 10mb version of the RACADM, now Im downloading another version, bigger (its an ISO), that seems to have solved the problem for a user in a similar situation. I dont think its gonna solve my problem but, well... Im out of ideas right now hehe.


That was the msg I got after trying the "racadm racresetcfg":

C:\Windows\system32>racadm racresetcfg


C:\Windows\system32>racadm racresetcfg

The RAC is unable to communicate with the BMC. This condition may
occur because of (1) no BMC is present, (2) missing or disfunctional
IPMI-related software components. Many RAC features depend on BMC
connectivity in order to work properly, and you may see failures
as a result.
ERROR: RACADM is unable to process the requested subcommand because there is no
local RAC configuration to communicate with.

Local RACADM subcommand execution requires the following:

 1. A Remote Access Controller (RAC) must be present on the managed server
 2. Appropriate managed node software must be installed and running on the

This ISO I've tried only gives me option to access the IDRAC trough HTTP, but it didn't reach anything with the HOSTNAME/IP ADDRESSES I've tried, sadly. I will keep looking for more information about that problem.


Looks like iDRAC have an issue and racadm is not able to communicate to iDRAC due to that. What server you have and which racadm version you installed? Are you seeing any error related to iDRAC during booting. If your server have LCD can you check what message shown on LCD?

DELL-Shine K

Latest Solutions
Top Contributor