forforum
1 Copper

How to configure OME to communicate to iDRAC 7 over IPMI?

Hi, I am having problems with getting my test OME to talk to and R620 over IPME. On the R620, I did the setting on iDRAC, as the following:

My iDRAC version:

While this is my set up on OME. I did not set up the rest like SNMP because we do not want to communicate over SNMP:

Can any kind soul kindly help me?

Tags (3)
0 Kudos
7 Replies

Re: How to configure OME to communicate to iDRAC 7 over IPMI?

Hi,

     Can you check whether the iDRAC username you are trying on OME have "IPMI Lan" Privilege. Also you can check whether you can run IPMI commands to iDRAC from a client machine

Thanks-


Shine

0 Kudos

Re: How to configure OME to communicate to iDRAC 7 over IPMI?

0 Kudos
forforum
1 Copper

Re: How to configure OME to communicate to iDRAC 7 over IPMI?

Hi,

Yes, there is IPMI over LAN privilege. But, may I know what is EG Key? Is it the "Ecryption Key" in the 1st image?

"whether you can run IPMI commands to iDRAC from a client machine", sorry, I am not really sure how I can do this.

Thanks

0 Kudos
forforum
1 Copper

Re: How to configure OME to communicate to iDRAC 7 over IPMI?

Hi, I read through this document before trying out, doesn't help much.

0 Kudos

Re: How to configure OME to communicate to iDRAC 7 over IPMI?

KG Key and Encryption Key is same.

To run ipmi command you can install below utility on windows client

www.dell.com/.../poweredge-r620

Traverse to "c:\Program Files (x86)\Dell\SysMgt\bmc" folder for 64 bit client OS or "c:\Program Files\Dell\SysMgt\bmc" for 32 bit client OS and run follwing ipmi command

ipmitool -I lanplus -H <iDRAC IP Address> -U <iDRAC Username> -P <iDRAC Password> delloem sysinfo

Thanks-


Shine

0 Kudos
Highlighted
DELL-Raj S
2 Iron

Re: How to configure OME to communicate to iDRAC 7 over IPMI?

iDRAC 7 can be managed using WS-MAN, SNMP and IPMI protocols (in the order of preference). To discover a iDRAC 7 using IPMI protocol from OME, provide iDRAC credentials and enter the KG Key as "000000" in the discovery wizard. Make sure to turn off SNMP protocol.

Follow these steps to receive alerts in OME from iDRAC 7:

Enabling or Disabling Alerts in iDRAC 7

For sending an alert to configured destinations or to perform an event action, you must enable the global alerting option. This property overrides individual alerting or event actions that is set.

Using iDRAC 7 console:

To enable or disable generating alerts:

1) In iDRAC7 Web interface, go to Overview → Server → Alerts. The Alerts page is displayed.

2) Under Alerts section:–

Select Enable to enable alert generation or perform an event action.–

Select Disable to disable alert generation or disable an event action.

3) Click Apply to save the setting.

Configuring IP Alert Destinations

You can configure the IPv6 or IPv4 addresses to receive the IPMI alerts or SNMP traps.

Configuring IP Alert Destinations Using Web Interface

To configure IPv4 or IPv6 alert destination settings using Web interface:

1) Go to Overview → Server → Alerts → SNMP and E-mail Settings.

2) Select the State option to enable the IP address to receive the traps and enter the OME system IP address for IPV4. You can specify up to four IPv4.

3) Enter the iDRAC7 SNMP community string. For more information about the options, see the iDRAC7 Online Help.

NOTE: The Community String value indicates the community string to use in a Simple Network Management Protocol (SNMP) alert trap sent from iDRAC7. Make sure that the destination community string is the same as the iDRAC7 community string. The default value is Public.

4) To test whether the IP address is receiving the IPMI or SNMP traps, click Send under Test IPMI Trap and Test SNMP Trap respectively.

5) Click Apply. The alert destinations are configured.

0 Kudos
forforum
1 Copper

Re: How to configure OME to communicate to iDRAC 7 over IPMI?

Hi Dell-Raj,

Thank you so much for your reply.

I have followed all you steps. Now I can see the equipment appears in my test server, however other than ON/OFF status, the rest are unknown. Previously I have changed Encryption Key on IDRAC7 before, I suppose that now I changed it back to "000000", so that it matches with what I keyed into OME, right?

The test IPMI alert that sent from iDRAC is also not received on the test server.

Thanks

0 Kudos