Systems Management General

Last reply by 04-09-2021 Solved
Start a Discussion
2 Bronze
2 Bronze
8833

How to repair iDRAC7 after bad firmware update

Hi all,

Before I start, it should be noted that the warranty has already expired for this machine.

I recently attempted an iDRAC7 firmware update on my Dell R320. I stepped out for a few minutes and when I came back I was greeted with a screen warning me that idrac could not be initialized. If I press F1 a few times, I can manage to boot into the OS. However the fans are quite loud, idrac is completely unresponsive, and the lifecycle controller option is also disabled.

I have already cleared flea power by unplugging the system completely and holding the power button for 30 seconds. I have also attempted clearing nvram by moving the jumper on the motherboard.

I have tried to run the platform specific bootable iso in order to update idrac again, but it seems to wait at "Getting System Inventory ..." until I reboot the machine.

I have also loaded into the SLI bootable iso and attempted to run multiple different versions of the iDRAC firmware update .bin. They all give some error about the system not being compatible.

I have even tried running "racadm fwupdate -d -u -p firmimg.d7" (for multiple different version of the iDRAC firmware) while loaded into the SLI iso at no avail. Something about not being able to perform this action.

I have read some things about updating firmware via console port, but I am not sure how i would go about this, also I don't yet have the required cable.

Is there anything else I can try? Or is my motherboard toast? If I were to buy a new board (probably used from eBay,) would I be able to transfer the iDRAC7 enterprise license from my current board?

Thanks,
Frnot

Replies (15)
1207

Do you have any of the versions prior to 1.46? mine is on 1.30 and it still says no compatible components when updating  to 1.46 from 1.30

1203

Hello,

 

Unfortunately, I'm not seeing any earlier downloads available. What version is your Lifecycle Controller, though? Depending on what version it is, updating that may fix the problem. If it is below 1.4.2, try the update below and see if it helps.

 

https://dell.to/39YihZp;

#Iwork4Dell
2 Bronze
2 Bronze
2912

The manufacturer is generally responsible for a defect discovered after the product has been placed on the market.
This is a latent (hidden) addiction to this Dell product.
Many have this problem after updating the BIOS, etc. They know the problem and ignore their consumers.
Dell, honestly, must replace the card (or rewrite the ROM) even after the warranty, as the problem is hidden until the update (provided by Dell) or mysterious reboot.
For Dell the cost would be small considering that it would reuse motherboards and just rewrite, but it would be very respectful to the consumer.

2894

Hi @Vacari,

 

Could PM me your case number or service tag of the system, I'll check if I can reach out any of the support services to help you. 


DELL-Joey C
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#IWork4Dell

Did I answer your query? Please click on ‘Accept as Solution’. ‘Kudo’ the posts you like!

1792

Hi Joey C,
I appreciate your contact and willingness to help. The service tag is <Service Tag removed>.
Have a nice day!

1782

Hello @Vacari,

 

Thank you for the Service Tag information. But please, make sure to edit your message and delete the Service Tag information as this should not be public. Do you remember from which iDRAC/BIOS firmware version were you updating from? Was it a very old one? I have seen this happening in the past, it used to happen when updating from a old version to the newest one.

 

I am afraid I see your system is a PowerEdge T320 out of warranty since 2016. It is not possible to replace the motherboard for this system with the expired warranty. But there are a bunch of this you can try.

First, the Drain Power option: How do I Reset and Drain Power of my Dell PowerEdge Server?

 

Then you can try to reset the iDRAC: How to reset the internal Dell Remote Access Controller (iDRAC) on a PowerEdge server? 

 

And of course, the iDRAC Recovery Procedure with firmimg.d7 

 

You can also try to clear the NVRAM if you are able to identify the jumper and shifting its position (this operation can be different depending on the PowerEdge server).

 

If none of this possibilities help you to solve the problem, then I am sorry, the only option left is to replace the motherboard.

 

Regards.


Diego López
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#Iwork4Dell

Did I answer your query? Please click on ‘Accept as Solution’
‘Kudo’ the posts you like!
Latest Solutions
Top Contributor