Highlighted
2 Bronze

How to update the BMC on R410 without idrac

I have an r410 with no idrac. Is there a way to update the BMC without needing to install an OS?

 

If so, is there a step by step guide? I have had absolutely no luck finding any documentation on this. I am trying to update the BMC to assist with the fan noise. Otherwise I will have to get rid of the server. 

0 Kudos
Reply
6 Replies
Highlighted
Moderator
Moderator

Antonio C,

 

If you go to the download page for the update here, it shows you an MS-DOS mode of updating (Installation Instructions), that is what I suggest you look into. The process is as follows;

 

Download

1. Click the Download Now link to download the file.
2. If the Export Compliance Disclaimer window appears, click the I agree link to accept the agreement.
3. When the File Download window appears, click Save to save the file to your hard drive.


Extract Files

1. Browse to the location where you downloaded the file and double-click the new file to unzip the download package.
2. Specify the location to unzip the files.
3. Click on the unzip button to extract files.

Additional Instructions

MS-DOS Version
1. copy the firmware image file, firmimg.d6, the DOS executable,bmcfwud.exe, and config file, bmcfwu.cfg, to a bootable USB key/floppy in the same directory.
2. boot off this media and execute "bmcfwud.exe" from the directory where the firmware image file exists. "-i" option can be used to specify the exact image path if not in the same directory.
3. Reboot the system to the same media as prompted.
4. Execute "bmcfwud.exe" again to complete the firmware update.
5. Reboot the system
 
 
Let me know how it goes.
 
 
 
 

Chris Hawk

Dell | Social Outreach Services - Enterprise
Get Support on Twitter @DellCaresPro 
Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

Reply
Highlighted
2 Bronze

Hi Chris,

 

Which version is the MS-DOS version?

 

I only see:

 

File Format:Hard-Drive
File Name:PER410BmcA01.exe
 
File Format:Update Package for Microsoft® Windows®
File Name:BMC_FRMW_WIN_R234180.EXE
 
File Format:GnuPG Signature for Linux Update Package
File Name:BMC_FRMW_LX_R234180.BIN.sign
 
File Format:Update Package for Red Hat Linux
File Name:BMC_FRMW_LX_R234180.BIN
 
Thank you
0 Kudos
Reply
Highlighted
Moderator
Moderator

The first one listed as hard drive, just run it and it will extract.


Thanks,
DELL-Josh Cr
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
#IWork4Dell
Reply
Highlighted
2 Bronze

Thank you Josh.

 

Side  question: how do i tell which "revision" my r410 is? I do not have access to iDRAC or OMSA

0 Kudos
Reply
Highlighted
2 Bronze

Hi @DELL-Chris H  @DELL-Josh Cr and @Antonio C I hope you don't mind me reviving this semi-recent thread.

If you want to get to the question at hand, scroll down to the "QUESTION" header.

I realize that updating the BMC shouldn't do much if you have an iDRAC in there. But let's just say that this is an exercise and I'm annoyed enough by my misbehaving server, that I really want to make this work 😄 

 

=== Intro story first. ===

I've had a rather interesting time upgrading the firmware on my R410 🙂

Updating the BIOS and the LCM was done from a CentOS 6.5 live CD, which worked pretty well! I wish I could've done the upgrade through the iDRAC, but apparently with my 6 that's not an option. Fair enough. 

The BMC update had a lot more trouble! Trying to run that on CentOS 6 (a RHEL 6 derivative) proved almost impossible due to $PATH issues in the "sourcing" of shell scripts and the dependency on non-standard binaries (from procmail) and older C libraries. I got a long way, but still the tool wouldn't run well. 

Which is why I was very happy to find this thread! I followed Josh' advice of making a FreeDOS boot image (which I found out could not work on USB drive, so I had to burn a DVD), and then extracting the PER*.exe file to put the DOS updater onto a USB stick. Mind you: the USB stick must be connected before booting FreeDOS, as FD itself does not have USB drivers. 

The BMC updater runs, but now threw a warning: "No valid device was found. Check to ensure system and flash image are valid.

Checking the revisions I found: 

Current Image
Firmware 2.92.05 1.15.02
Bootloader 1.13.8 1.12.46

Turns out the iDRAC was in the way. So I removed it completely.

 

=== QUESTION ===

After removing my iDRAC modules (both) and booting into FreeDOS, I ran the bmcfwud command as suggested by Josh. It came from the extracted PER*.exe file to which Josh had provided the link

Running "bmcfwud -r" now tells me that the current BMC firmware version is 1.54.22. So I still cannot update it. 

How is that possible?! According to Dell's own support site, the maximum version is 1.15.

And according to the LCM and iDRAC, the BMC firmware version was actually 1.11! So there's a big disconnect here!

0 Kudos
Reply
Highlighted
2 Bronze

As a quick follow-up: it's interesting that the Dell support page for R410 says the highest BMC version is 1.15 A01, while this page over here is for 1.33 A03. So that'd suggest the main page for R410 is also not on the up-and-up.

EDIT:

Well I'll be darned! Googling for "Dell BMC firmware 1.54" led me to this Dell Support page.

What do you know?! It does exist! So why is that not listed on the main R410 page?? And how'd it get onto that antique system? I guess it might have been part of the iDRAC6 monolithic update. What'd you think?

There's even 1.70 A00, how about that?

0 Kudos
Reply