Highlighted
ahongens1
1 Nickel

M1000e CMC does not talk RFC-compliant SMTP?

Hey, I have an issue with my M1000e CMC, and sending alerts through SMTP.

Whenever I tell the CMS to send a test alert, it connects to my mail server (running postfix-2.4.6,1 on FreeBSD), and the following conversation happens:


> HELO [10.94.206.15]

> MAIL FROM: AUTH=<>
<>
> QUIT


Is there any way I can tell the CMS to stop sending the auth=<> command, or do you guys perhaps know of a way for postfix to accept the auth=<> tag in this format?

By the way, the postfix is a quite default installation, and I don't use any authentication mechanisms, only the trusted_networks thingy..
0 Kudos
2 Replies

RE: M1000e CMC does not talk RFC-compliant SMTP?

Sorry for the delay in response. Below is what I got back from engineering which will help solve the problem.

I believe that configuring postfix as described starting http://postfix.state-of-mind.de/patrick.koetter/smtpauth/requirements.html
should allow his postfix MTA to accept/pass the mail.

Also, note also RFC 2554 is obsoleted by RFC 4954 (July 2007), which describes the AUTH parameter here: http://tools.ietf.org/html/rfc4954#page-9

Please let me know if this helps.
0 Kudos
ahongens1
1 Nickel

RE: M1000e CMC does not talk RFC-compliant SMTP?

You are totally right, after enabling SMTP auth, it works like a charm, and postfix accepts it.

Now I have to find out how I can have the Exchange 2007 machine in our office accept mail from that email addres.. It now says "501 5.1.7 Invalid address (in reply to MAIL FROM command)", because the from-address is "".

Can I set that sender address somewhere in the CMC? Or any smart ideas for now on how to have Exchange accept that? I will google.. If I can't find anything, I can always try to do some magic with the postfix in between (like send to a local account on the postfix machine, and forward it to an account on the exchange).
0 Kudos