TamSten
1 Nickel

PowerEdge T320 iDrac physical disk status unknown

I just purchased an iDrac Express license for my out-of-warranty- T320.  The physical disks' "Status" are showing a status of "?" or "Uknown."  The "State" appears correct (e.g. Online, Online, Online, and Ready (hot spare)).

Last time I saw this, I was able to resolve by updating firmwares, but I have updated iDrac, RAID, BIOS, and disk firmwares to newest versions and still not showing appropriate status.

I'm setting up SNMP monitoring of the drives and this "Unknown" status is throwing me into an error state.

Any assistance appreciated.

0 Kudos
5 Replies
Highlighted
Moderator
Moderator

Re: PowerEdge T320 iDrac physical disk status unknown

Hello

The three things I can think of that would affect what is displayed are the iDRAC/LCC firmware, storage controller, and physical disks. When updating the iDRAC/LCC firmware, make sure you are using the combined update to get the latest. The iDRAC7 released with separate updates for the iDRAC and LCC. The firmware update was combined with version 2.0. The combined update is listed under a different category on the support page.

http://www.dell.com/support/

http://www.dell.com/storagecontrollermanuals/

The information listed in the iDRAC web GUI may be limited depending on the storage controller you are using or whether or not you are using supported disk drives.

Thanks

Daniel Mysinger
Dell EMC, Enterprise Engineer

Get support on Twitter @DellCaresPRO

0 Kudos
TamSten
1 Nickel

Re: PowerEdge T320 iDrac physical disk status unknown

I did use the combined iDrac/LCC driver.  Current version is 2.61.60.60 (latest).

RAID adapter is PERC H710 on firmware version 21.3.5-0002 (latest).

Drives are the ones that came with the server, and thus I would imagine are supported.  They are Seagate ST1000NM0001 on revision PS08 (latest).

0 Kudos
Reybeast2
1 Copper

Re: PowerEdge T320 iDrac physical disk status unknown

my suggestions: make sure that the Collect System Inventory on Restart is enabled in the Bios/idrac, the system should be powered on to show the current information. You could also try rebooting the idrac, SSH into the idrac IP, then run racadm racreset, Or shut down the system, pull the power cords for ~30 seconds, then boot up. 

TamSten
1 Nickel

Re: PowerEdge T320 iDrac physical disk status unknown

Wanted to mention that the drives show up OK in OMSA.

0 Kudos
sabedevops
1 Copper

Re: PowerEdge T320 iDrac physical disk status unknown

Are there any other recommended troubleshooting steps for this issue? We have an R430 with an H310 controller that is showing this shame issue, along with some other hosts.

The WS-Man request for the DCIM_ControllerView (as well as the racadm and other means of getting the status, including via the iDRAC system inventory page) show a PrimaryStatus of Unknown (numerically where appropriate=0). According to the documentation, this uknown status is intentional, but it's not clear on what conditions give way to it.

Some things we've tried:

1) All firmware up to do (and re-installed twice).

2) Inventory Collection on Restart is enabled.

3) We have a 4 disks attached to the controller. We switched between RAID mode and HBA mode, with no effect. We created a virtual disk with 2 out of the 4 controllers (back in RAID mode), thinking this might initialize some obscure data structure, with no effect. Is there something regarding this we are not aware of?

4) We unplugged the system for 30 minutes, and plugged it back in.

5) We conducted both hard and soft rac resets.

6) We've followed the hacky solutions posted by other users, like resetting the iDRAC and simply looking at the controller/disks in both the configuration utility and the lifecycle controller.

The only thing we haven't tried, is taking these servers apart and physically reconnecting the H310 card or messing with jumpers.

There are at least a dozen posts regarding this set of issues, and none of them provide an account of a root cause. Can we get a more comprehensive answer?

Thanks!

0 Kudos