ClxAdmin
1 Nickel

Re: iDRAC problem on Dell R610

Jump to solution

Thanks for the update powerman-asdf, will try and get a Dell Engineer out to replace the motherboard in our server.

We are using Linux with a H200 controller but we're running Red Hat 5.6 on, we've also had Red Hat 6.0 on and didn't have any noticeable problems. It's currently running kernel 2.6.33.9-rt31.64.el5rt, the non RealTime kernel was also fine. The install was done via PXE/KS/NFS.

I think the problem mentioned in the bug report relates to an Ubuntu/kernel problem and not the hardware.

0 Kudos
powerman-asdf
1 Nickel

Re: iDRAC problem on Dell R610

Jump to solution

I'm now downloading RHEL to compare driver sources with my kernel.

Can you please confirm your system uses mpt2sas driver, and provide kernel boot output/dmesg related to this driver?

0 Kudos
ClxAdmin
1 Nickel

Re: iDRAC problem on Dell R610

Jump to solution

Below is the dmesg output, we're only using the one SAS disk.

SCSI subsystem initialized
mpt2sas version 03.100.03.00 loaded
scsi0 : Fusion MPT SAS Host
mpt2sas 0000:03:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
mpt2sas 0000:03:00.0: setting latency timer to 64
mpt2sas0: 64 BIT PCI BUS DMA ADDRESSING SUPPORTED, total mem (16454708 kB)
mpt2sas 0000:03:00.0: irq 61 for MSI/MSI-X
mpt2sas0: PCI-MSI-X enabled: IRQ 61
mpt2sas0: iomem(0xd92b0000), mapped(0xffffc90012c60000), size(65536)
mpt2sas0: ioport(0xfc00), size(256)
mpt2sas0: sending diag reset !!
mpt2sas0: diag reset: SUCCESS
mpt2sas0: Allocated physical memory: size(1154 kB)
mpt2sas0: Current Controller Queue Depth(499), Max Controller Queue Depth(2607)
mpt2sas0: Scatter Gather Elements per IO(128)
mpt2sas0: LSISAS2008: FWVersion(07.15.04.00), ChipRevision(0x03), BiosVersion(07.11.01.00)
mpt2sas0: Dell PERC H200 Integrated: Vendor(0x1000), Device(0x0072), SSVID(0x1028), SSDID(0x1F1E)
mpt2sas0: Protocol=(Initiator,Target), Capabilities=(Raid,TLR,EEDP,Snapshot Buffer,Diag Trace Buffer,Task Set Full,NCQ)
mpt2sas0: sending port enable !!
mpt2sas0: host_add: handle(0x0001), sas_addr(0x5782bcb0162adb00), phys(8)
mpt2sas0: failure at drivers/scsi/mpt2sas/mpt2sas_scsih.c:3911/_scsih_add_device()!
mpt2sas0: port enable: SUCCESS
scsi 0:0:0:0: Direct-Access     FUJITSU  MBD2147RC        D809 PQ: 0 ANSI: 5
scsi 0:0:0:0: SSP: handle(0x000a), sas_addr(0x500000e11716a7d2), device_name(0xe1000050d1a71617)
scsi 0:0:0:0: SSP: enclosure_logical_id(0x5782bcb0162adb00), slot(0)
scsi 0:0:0:0: qdepth(254), tagged(1), simple(1), ordered(0), scsi_level(6), cmd_que(1)
sd 0:0:0:0: [sda] 286749480 512-byte logical blocks: (146 GB/136 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: c7 00 00 08
sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
 sda: sda1 sda2 sda3
sd 0:0:0:0: [sda] Attached SCSI disk

[root@server ~]# modinfo mpt2sas
filename:       /lib/modules/2.6.33.9-rt31.64.el5rt/kernel/drivers/scsi/mpt2sas/mpt2sas.ko
version:        03.100.03.00
license:        GPL
description:    LSI MPT Fusion SAS 2.0 Device Driver
author:         LSI Corporation <DL-MPTFusionLinux@lsi.com>

0 Kudos
ClxAdmin
1 Nickel

Re: iDRAC problem on Dell R610

Jump to solution

I finally got around to getting a Dell Engineer out to replace the motherboard, and would you believe, problem sorted.

0 Kudos
Highlighted
ClxAdmin
1 Nickel

Re: iDRAC problem on Dell R610

Jump to solution

I got a follow up email from Dell and they said that they've seen this issue with a number of customers and that the commonality between them is that they were all running iDRAC firmware 1.70. They also noticed that it took a long time to downgrade the firmware and had to be done offline. It's probably best to avoid that firmware.

0 Kudos
fjan11
1 Copper

Re: iDRAC problem on Dell R610

Jump to solution

For anyone else with this problem, this worked for me:

http://permalink.gmane.org/gmane.linux.hardware.dell.poweredge/42033

0 Kudos
djayo
1 Copper

RE: iDRAC problem on Dell R610

Jump to solution

SOLUTION

To see settings for IDRAC Card

C:\Users\Administrator>racadm getniccfg

 

To Select Dedicated IDrac Port from LOM1

 

C:\Users\Administrator>racadm config -g cfgLanNetworking -o cfgNicSelection 2

Object value modified successfully

 

To Disable DHCP for Dedicated Port

C:\Users\Administrator>racadm config -g cfgLanNetworking -o cfgNicUseDhcp 0

Object value modified successfully

 

To Set IP Adress for Dedicated Port

C:\Users\Administrator>racadm config -g cfgLanNetworking -o cfgNicIpAddress 192.168.1.119

Object value modified successfully

 

To Import IDRAC License

C:\Users\Administrator>racadm license import -f C:\license.xml -c idrac.embedded.1

0 Kudos
markgu
1 Copper

RE: iDRAC problem on Dell R610

Jump to solution

Even with the platform firmware up-to-date as of October 2014 this issue still persists.


Many thanks Fjan11for the fix!

0 Kudos
TechJJ
1 Copper

Re: iDRAC problem on Dell R610

Jump to solution

The article works, but the link to the tools is wrong. Google "Broadcom NetXtreme Family of Adapters, NetXtreme II Family of Adapters, v.14.2.0, A03", or "Dell Drivers 29DKK" (should take you to www-DOT-dell-DOT-com/support/home/us/en/04/drivers/driversdetails?driverId=29DKK). That fixed it for me as well. Thanks!

0 Kudos